🎃

Strapiから取得したデータをGatsby.jsのGraphQLで表示するとおかしくなる

2022/01/18に公開約500字

結論 Strapiのバージョンのせい

2022年1月18日現在、  Gatsby.jsとStrapi v4は相性が悪い。

こうなってませんか?
僕は変な階層になったり、RELATIONで設定したカテゴリが取得できず詰まった。

Strapi v3.6.8にダウングレードしたら、正常に取得できた。
ダウングレード方法はこちら

nodeのバージョンがv14.x.xまでなので、
おそらくnodeのダウングレードも必要になります。

https://zenn.dev/flutternyumon/articles/d91fd6c3278deb

Gatsby.jsがよくわからない方にオススメの本

  • 【特典付き! 】Webサイト高速化のための 静的サイトジェネレーター活用入門 (Compass Booksシリーズ)

https://amzn.to/3tyqkoK
  • React & Gatsby開発入門
    Reactが良くわかってない方でも読めるかと思います。

https://amzn.to/3sPjmwo

Discussion

ログインするとコメントできます