🐡

[エラー][Mac][npm] npm install -g firebase-toolsでエラー

2022/09/04に公開約1,700字

やりたいこと

npm install -g firebase-tools

エラー内容

インストールできない。

$ npm install -g firebase-tools  
npm WARN deprecated har-validator@5.1.3: this library is no longer supported
npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
(##################) ⠋ reify:googleapis: timing metavuln:calculate:security-advisory:firebase-functions:SyoPXa/u8BwcDRN/qldTotTJ9bZQ+J7uoM5Nw
added 706 packages, changed 1 package, and audited 708 packages in 2m

39 packages are looking for funding
  run `npm fund` for details

27 vulnerabilities (20 moderate, 7 high)

To address issues that do not require attention, run:
  npm audit fix

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.

言われた通り、npm audit fixを実行してもだめでした。

原因

nodeとnpmのバージョンが良くなかったかも。

解決策

nodebrewでnodeバージョンを変更

nodebrew install 16.4.2
nodebrew use 16.4.2
node -v
16.4.2

もう一度npm install

npm i -g firebase-tools

実行すると、npm audi fixを実行しろと言われたので実行する。

npm audi fix

無事インストールできました。

npm list

└── firebase-tools@11.8.0

依存関係が原因だったのかな。。

正直明確な原因はわかりませんでしたが、Nodeとnpmのバージョンが怪しいことが多いので、まずは各バージョンを確認すると良いかもしれません。

Discussion

ログインするとコメントできます