🚨

Pycharmで出る「JSHint: 'import' is only available in ES6」などの警告への対応方法

2022/12/20に公開約700字

pycharmでJavaScript(ES6記法)を書いていると警告が出てしまう。

原因はJavaScriptの構文チェックを行うものがES6で設定されていないからみたい。(デフォルトでは旧バージョンであるES5の構文チェックであるため未知の構文(ES6)に対応できていない)

【解決策】
「Pycharm」 → 「Settings(又はPreference)」

「Languages & Frameworks」→「JavaScript」→「Code Quality Tools」→「JSHint」

以下の設定項目の「Set」を押して、設定値を「6」にする。

「OK」を押して設定を保存すると、警告が消えました。おわり。

Discussion

ログインするとコメントできます