Closed3
std::span/std::mdspan系譜図
共通祖先
- 2014-01-17, N3851 Multidimensional bounds, index and array_view :
array_view
- N3976(r2), N4087(r3), N4177(r4), N4346(r5), N4494(r6)
- 2015-05-07, N4512 Multidimensional bounds, offset and array_view, revision 7 :
array_view
std::span
(C++20)
- 2015-09-25, P0122R0 array_view: bounds-safe views for sequences of objects :
array_view
- "The design of the
array_view
type discussed in this paper is related to thearray_view
previously proposed in N3851 and also drew on ideas in thearray_ref
andstring_ref
classes proposed in N3334."
- "The design of the
- 2016-02-11, P0122R1 span: bounds-safe views for sequences of objects :
span
- "Changed the name of the type being proposed from
array_view
tospan
following feedback from LEWG at the Kona meeting." - "Removed multidimensional aspects from the proposal.
span
is now always single-dimension and contiguous."
- "Changed the name of the type being proposed from
- 2018-03-16, P0122R7 span: bounds-safe views for sequences of objects :
span
(Adopted 2018-03)
std::mdspan
(C++23)
- 2015-09-23, P0009R0 Polymorphic Multidimensional Array View :
view
- "Thus we choose the name
view
as opposed toarray_view
in anticipation of this new fundamental mechanis for viewing spans of memory with an easily extensible set of properties."
- "Thus we choose the name
- 2016-02-04, P0009R1 Polymorphic Multidimensional Array Reference :
array_ref
- "Revised with renaming from
view
toarray_ref
and allow unbounded rank through variadic arguments." (quote from P0009R2)
- "Revised with renaming from
- 2016-10-14, P0009R3 Polymorphic Multidimensional Array Reference :
array_ref
- "Note that the
array_ref
name in this paper is not entirely satisfactory and the following alternatives were brainstormed during prior LEWG reviews." - "LEWG 2015-10-22: view, span, array_ref, slice, array_view, ref, array_span, basic_span, object_span, field"
- "LEWG 2016-06-25: sci_span, numeric_span, multidimensional_span, multidim_span, md_span, vla_span, multispan, multi_span"
- "Note that the
- 2017-10-11, P0009R4 Polymorphic Multidimensional Array Reference :
mdspan
- "Rename to
mdspan
, multidimensional span, to align with P0122r5span
."
- "Rename to
- 2022-07-13, P0009R18 MDSPAN :
mdspan
(Adopted 2022-07)
もともとarray_viewだったが、今ではmdspanという一見してわけのわからない名前になっている。これは、viewという用語が適切ではないという意見によって変更された。
しかし、連続したストレージを所有しない多次元配列に見せかけるラッパークラスとして、mdspanという名前は本当に通じるのだろうか。これはもともとarray_viewと呼ばれていたが、viewという用語は正しくないと物言いがついたために、spanになった。
We talked with people in the library working group in the standards committee. They wanted the
array_view
they are trying to get into the standard to be read only. For the core guidelines, we needed an abstraction that was read and write. To avoid a clash between the (potential) standards and the guidelines support library (GSL), we renamed our (read and write)array_view
tospan
: https://github.com/microsoft/gsl.
answered Jan 16, 2016 at 22:26, Bjarne Stroustrup
このスクラップは2023/03/16にクローズされました