💭

qarv-qt5を実行できる環境を構築してみた。

2022/03/08に公開

Ubuntuに入れてみる。

$ git clone https://github.com/sudorook/qarv-qt5
$ cd qarv-qt5
$ mkdir build
$ cd build
$ cmake ..
$ make
$ sudo make install

素のUbuntuだと上記のみだとエラーが発生する。
依存関係をインストールする。

$ sudo apt install qtbase5-dev
$ sudo apt install libqt5svg5-dev
$ sudo apt install libopencv-dev
aravisをインストール
$ git clone https://github.com/AravisProject/aravis
$ cd aravis
$ sudo apt install autoconf intltool python-gobject-dev gobject-introspection gtk-doc-tools libgstreamer0.10-dev python-gst0.10-dev libxml2-dev
$ ./autogen.sh
$ make 
$ sudo make install
$ sudo ldconfig

qarv5のbuildディレクトリに戻りmakeする。

$ cmake ..
$ make
$ ./qarv

以上

Discussion

ログインするとコメントできます