Error: Your Xcode does not support macOS 11.0.が出た時の対処方法

1 min読了の目安(約1000字TECH技術記事

前提

  • maxOS BigSur Beta9
  • Xcode 12.0.1

起きたこと

macOS Big Sur Beta9を使っていて、Homebrew経由でDartをインストールしようとしたところ、次のエラーに遭遇した。

$ brew install dart
Warning: You are using macOS 11.0.
...
Error: Your Xcode does not support macOS 11.0.
It is either outdated or was modified.
Please update your Xcode or delete it if no updates are available.

XcodeがmacOS11(BigSur)をサポートしていない、ということらしい。

対処方法

次のイシューを読むと、Command Line Tools for Xcode 12.2 beta 2からは、macOS11.0 SDKが含まれているらしい。

homebrew installation fails on macOS 11 (Big Sur) · Issue #962 · GoogleContainerTools/kpt

次のリンクから、Command Line Tools for Xcode 12.2 beta 2 をダウンロードし、インストールする。
More Software Downloads - Apple Developer

これで問題が解決した。

参考文献

homebrew installation fails on macOS 11 (Big Sur) · Issue #962 · GoogleContainerTools/kpt