😭

Tips: Mintでのインストールに失敗した話

1 min read

事象

いつものようにmint install realm/SwiftLintしたら、以下のエラーが発生しました。

error: Failed to clone https://github.com/jpsim/Yams.git:
    Cloning into bare repository '/private/var/folders/v6/33wfdzxd4fx7_59fq5wrv59h0000gn/T/mint/github.com_realm_SwiftLint/.build/repositories/Yams-00fc82b0'...
🌱 Encountered error during "swift package resolve"
🌱  Failed to resolve SwiftLint 0.41.0 with SPM

今までこんなエラー発生したことなかったのに・・。と焦りました。。

原因

よくエラーを見ているとbare repositoryのクローンに失敗しているようです。
とりあえずgitconfigを見てみると以下のようになっていました。

[core]
    bare = false

とりあえずbare=trueにすることで、今回のエラーは解消されました。

まとめ

bare repositoryってなんだ。。知識不足つらい。。

Discussion

ログインするとコメントできます