Closed1

JupyterLab3.0の環境構築メモ

krassowski/jupyterlab-lsp: Language Server Protocol integration for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename)

JupyterLabは3系を指定。Pythonのバージョンは、3.9 だと未対応のパッケージがありそうというくらいの理由。

py -m pipenv --python 3.8
py -m pipenv install jupyterlab=3.0 jupyterlab-lsp python-language-server[all]

上記コマンドでインストールされたパッケージの一部

  • jupyterlab: 3.0.4
  • jupyterlab-lsp: 3.0.0
  • python-language-server: 0.36.2
  • jupyter-lsp: 1.0.0 (依存パッケージとしてインストールされている)

jupyterlab-git も入れたかったが、2021年1月13日現在こちらはJupyterLab 3.xに まだ対応していない 模様。

このスクラップは1ヶ月前にクローズされました
ログインするとコメントできます