💬

JANOG51 NETCON 問題1-6解説

2023/02/03に公開

この記事はJANOG51 NETCONで出題された問題1-6の解説記事です。

問題文

以下2つのトラブルを解決してください

  • R1とR2でOSPFのneighborが張れない
  • R3からR1へpingできない

トポロジー図

制限事項

ログイン可能なのはR2、R3のみ

初期config

R1

! Command: show running-config
! device: R1 (cEOSLab, EOS-4.28.5.1M-30127723.42851M (engineering build))
!
no aaa root
!
dhcp server
   subnet 192.168.50.0/24
      range 192.168.50.1 192.168.50.30
      default-gateway 192.168.50.254
!
transceiver qsfp default-mode 4x10G
!
service routing protocols model ribd
!
hostname R1
!
spanning-tree mode mstp
!
interface Ethernet1
   mtu 9000
   no switchport
   ip address 192.168.10.1/30
   ip ospf cost 10
   ip ospf dead-interval 80
   ip ospf network point-to-point
   ip ospf area 0.0.0.0
!
interface Loopback1
   ip address 10.0.0.1/32
   ip ospf area 0.0.0.0
!
interface Management0
   ip address 172.20.20.2/24
   ipv6 address 2001:172:20:20::2/64
!
ip routing
!
router ospf 1
   max-lsa 12000
!
end

R2

! Command: show running-config
! device: R2 (cEOSLab, EOS-4.28.5.1M-30127723.42851M (engineering build))
!
no aaa root
!
transceiver qsfp default-mode 4x10G
!
service routing protocols model ribd
!
hostname R2
!
spanning-tree mode mstp
!
interface Ethernet1
   mtu 8500
   no switchport
   ip address 192.168.10.2/30
   ip ospf cost 10
   ip ospf dead-interval 80
   ip ospf network point-to-point
   ip ospf mtu-ignore
   ip ospf area 0.0.0.0
!
interface Ethernet2
   no switchport
   ip address 192.168.50.254/24
   ip helper-address 10.0.0.1
!
interface Loopback1
   ip address 10.0.0.2/32
   ip ospf area 0.0.0.0
!
interface Management0
   ip address 172.20.20.3/24
   ipv6 address 2001:172:20:20::3/64
!
ip routing
!
router ospf 1
   router-id 10.0.0.2
   no passive-interface Ethernet2
   network 192.168.10.0/30 area 0.0.0.0
   network 192.168.50.0/24 area 0.0.0.0
   max-lsa 12000
!
end

R3

! Command: show running-config
! device: R3 (cEOSLab, EOS-4.28.5.1M-30127723.42851M (engineering build))
!
no aaa root
!
transceiver qsfp default-mode 4x10G
!
service routing protocols model ribd
!
hostname R3
!
spanning-tree mode mstp
!
interface Ethernet1
   no switchport
   ip address 192.168.50.253/24
!
interface Management0
   ip address 172.20.20.2/24
   ipv6 address 2001:172:20:20::2/64
!
ip routing
!
ip route 0.0.0.0/0 192.168.50.254
!
end

問題解説

この問題は、R2のOSPF関連設定の誤りによってneighborが確立できない点とR3のEth1にIPv4アドレスが設定されていないためping疎通ができなくなっているという問題でした。

まず、R2のloggingレベルを7に変更します。
その後R2で以下を実行します。

R2# debug ip ospf event
R2# terminal moniter

これで、R1とR2の間でdead-intervalの値が異なっていることがわかります。
R2で以下の設定を入れます。

R2(config)# interface Ethernet1
R2(config)# ip ospf dead-interval 80

しかし、これだけではneighborが確立できません。
ここで、MTUの不一致であると推測しMTUに関係する設定を変更します。
R1の具体的なMTU値がわからないので、今回はignore設定を行います。

R2# interface Ethernet1
R2# ip ospf mtu-ignore

これにより、 R1-R2間でのOSPFのneighborを張ることができました。

R2#show ip ospf neighbor
Neighbor ID     Instance VRF      Pri State                  Dead Time   Address         Interface
10.0.0.1        1        default  0   FULL                   00:01:15    192.168.10.1    Ethernet1

続いて、R2のOSPF設定を実施します。

R2(config)# router ospf 1
R2(config-rpiter-ospf)# router-id 10.0.0.2
R2(config-rpiter-ospf)# no passive-interface Ethernet2
R2(config-rpiter-ospf)# network 192.168.10.0/30 area 0.0.0.0
R2(config-rpiter-ospf)# network 192.168.50.0/24 area 0.0.0.0

R2の初期コンフィグを見るとDHCP Relayを使うような設定が記載されていますがR2内で確認するとうまく動いていないことがわかります。
問題の要件としては、R3からR1へping疎通することなのでR3に静的にIPを設定し、デフォルトルートをR2に向けることでping疎通することができます。

R3(config)# interface Ethernet1
R3(config)# no switchport
R3(config)# ip address 192.168.50.253/24
R3(config)# ip route 0.0.0.0/0 192.168.50.254

これにより、R3からR1へping疎通することが可能になりました。

R3#ping 192.168.10.1
PING 192.168.10.1 (192.168.10.1) 72(100) bytes of data.
80 bytes from 192.168.10.1: icmp_seq=1 ttl=63 time=0.092 ms
80 bytes from 192.168.10.1: icmp_seq=2 ttl=63 time=0.019 ms
80 bytes from 192.168.10.1: icmp_seq=3 ttl=63 time=0.018 ms
80 bytes from 192.168.10.1: icmp_seq=4 ttl=63 time=0.016 ms
80 bytes from 192.168.10.1: icmp_seq=5 ttl=63 time=0.016 ms

--- 192.168.10.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.016/0.032/0.092/0.030 ms, ipg/ewma 0.050/0.061 ms

以上で問題の要件を満たすので解決となります。

最後に

今回初めてNETCONスタッフとして問題の出題を経験しました。
多くの方に挑戦していただけたのですごく楽しかったです。

Discussion