Closed2

flutter upgrade トラブルシューティング

$ flutter pub outdated
$ flutter pub upgrade
$ flutter clean
$ rm -rf Podfile.lock

flutter pub upgrade した後にflutter runすると以下のようにResolving dependencies of Podfile**** というメッセージが表示させる事がある。

その場合は一度 flutter clean して Podfile.lock を削除する

 Resolving dependencies of `Podfile`
      CDN: trunk Relative path: CocoaPods-version.yml exists! Returning local because checking is only perfomed in repo update
      CDN: trunk Relative path: all_pods_versions_0_3_5.txt exists! Returning local because checking is only perfomed in repo update
      CDN: trunk Relative path: Specs/0/3/5/Firebase/7.5.0/Firebase.podspec.json exists! Returning local because checking is only perfomed
Error: CocoaPods's specs repository is too out-of-date to satisfy dependencies.
To update the CocoaPods specs, run:
  pod repo update

Error running pod install
$ pod repo update
このスクラップは2021/04/30にクローズされました
作成者以外のコメントは許可されていません