🐷

every version of flutter_test from sdk depends on meta 1.3.0 and json_

1 min read

(今後同じようなエラーと遭遇した時ための備忘録として 2021年8月8日記述)

every version of flutter_test from sdk depends on meta 1.3.0 and json_annotation >=4.1.0 depends on meta ^1.4.0, flutter_test from sdk is incompatible with json_annotation >=4.1.0.

flutter SDKに入っているflutter testは、metaというパッケージの1.3.0なのに

json_annotation >=4.1.0は、metaというパッケージの^1.4.0なので、合ってないですよ

ってことらしい。

解決方法は、annotationのバージョンを1つ下げる。
json_annotation: ^4.1.0(最新) →  json_annotation: ^4.0.1

https://pub.dev/packages/json_annotation/versions

これでpub getをすると、今度は

json_serializable >=5.0.0 depends on json_annotation >=4.1.0 <4.2.0 which depends on meta ^1.4.0, json_serializable >=5.0.0 requires meta ^1.4.0.

というエラーが出てくる。

json_serializable >=5.0.0は、json_annotation >=4.1.0 に依存している。

>=なので、「4.1.0以上」を使えってことらしい。

先程と同じように、json_serializableのバージョンを下げる。
json_serializable: ^5.0.0(最新) →  json_serializable: ^4.1.4

https://pub.dev/packages/json_serializable/versions

これでpub get。

Discussion

ログインするとコメントできます