Closed2

[Unity]AdMobTestSuite最新版をUnityプロジェクトに導入する

TestSuiteは前から使ってたけど一応まとめておく。

SDK概要

https://developers.google.com/admob/unity/mediation-test-suite

アップデート情報

https://groups.google.com/g/google-admob-ads-sdk/c/H0OcUJqIQH8/m/XBBMoyv6BgAJ

iOSやAndroid用のプラグインに関しては導入ページにChangelogがあるが、なぜかUnityの方にはそれが載っていない。

https://developers.google.com/admob/ios/mediation-test-suite#changelog
https://developers.google.com/admob/android/mediation-test-suite#changelog

バージョンを上げたいとき

UnityのAdMobは現在6.1.0までリリースされているが、↑のGoogleGroupにはv1.6.0の更新が最後になっており、対応しているバージョンはそれぞれiOSが1.4.0、Androidが1.5.0となっている。
SDK概要のページからダウンロードできるSDKの中身もその通りになっている。
今回AdMob6.1.0を使いたく、それに対応しているSDKのバージョンはそれぞれiOSもAndroidも2.0.0を使わなければならない。

Assets/GoogleMobileAdsMediationTestSuite/Editor/GoogleMobileAdsMediationTestSuiteDependencies.xml

にそれぞれのバージョンが指定されているので、それを2.0.0に書き換えるだけで動いてくれれば最高なんですが、動くか確かめてみます。

<dependencies>
  <androidPackages>
    <androidPackage spec="com.google.android.ads:mediation-test-suite:1.5.0">
      <repositories>
        <repository>https://maven.google.com</repository>
      </repositories>
    </androidPackage>
  </androidPackages>

  <iosPods>
    <iosPod name="GoogleMobileAdsMediationTestSuite" version="1.4.0">
      <sources>
        <source>https://github.com/CocoaPods/Specs</source>
      </sources>
    </iosPod>
  </iosPods>
</dependencies>

動いた。最高!終了!

このスクラップは5ヶ月前にクローズされました
ログインするとコメントできます