🦁

yarn addでThe engine "node" is incompatible with this module.が出たときの対処法

2022/06/02に公開約900字

はじめに

Reactの学習中にThe engine "node" is incompatible with this module.というerrorが表示されたので、その解決方法を備忘録もかねて記事にしようと思います。

原因

調べてみると、インストールしているNode.jsのバージョンが非互換性が原因になっている様子。
更にerror文には以下の記載もあり。

Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.2.0"

求められているバージョンに対して、現時点でのバージョンが16.2.0だからいけないのかなと考察。

一応、node -vでバージョンの確認

% node -v
→ v16.2.0

やはりバージョンが違うのが原因っぽい

バージョンを固定してインストール

今回は16.10.0にします。

% nvm install 16.10.0
Downloading and installing node v16.10.0...
Downloading https://nodejs.org/dist/v16.10.0/node-v16.10.0-darwin-x64.tar.xz...
Computing checksum with shasum -a 256
Checksums matched!
Now using node v16.10.0 (npm v7.24.0)

バージョンの確認

% node -v
→ v16.10.0

無事にインストール完了

この後にyarn addを行ったところ問題なく実行することができました。

参考資料

yarn installで"The engine "node" is incompatible with this module"というエラーが発生した件

Discussion

ログインするとコメントできます