🐤

[Android] Jetpack ComposeとKotlinのバージョン関係

2022/05/20に公開約900字

起きたこと

新規プロジェクトを作成して Jetpack Compose を導入しようとした際に以下のエラーが発生した。

This version (1.1.1) of the Compose Compiler requires Kotlin version 1.6.10 but you appear to be using Kotlin version 1.6.21 which is not known to be compatible.  Please fix your configuration (or `suppressKotlinVersionCompatibilityCheck` but don't say I didn't warn you!).

原因

エラーの内容からも分かりそうだが、この記事によると、Jetpack Compose と Kotlin のバージョンに互換性がないといけないらしい。

対応方法

Android Developers の Compose と Kotlin の互換性マップ を読んでみると、Jetpack Compose のバージョンに互換性のある Kotlin バージョンが記載されていた。

Jetpack Compose v1.1.1 に対応しているのは Kotlin v1.6.10 だったため、Kotlin のバージョンを 1.6.21 から 1.6.10 に変更して無事に解決した。

build.gradle
...
implementation 'org.jetbrains.kotlin:kotlin-gradle-plugin:1.6.10'
...

Discussion

ログインするとコメントできます