🏹

Gatsbyをv3からv4へアップデートする

1 min read

Gatsby本体のアップデート

gatsbyを利用しているプロジェクトでgatsbyの最新版をinstallします。

yarn add gatsby@latest

Gatsbyの関連パッケージのアップデート

アップデートが必要なパッケージを確認します。

yarn outdated

赤文字で記載されている、gatsby-*で始まるパッケージを更新します。

一例として、gatsby-plugin-sharpのアップデートが必要な場合は下記の用にします。

yarn add gatsby-plugin-sharp@latest

更新が必要なパッケージを一括でアップデート

下記コマンドを利用します。

yarn upgrade-interactive --latest

gatsbyjs/gatsbyリポジトリで管理されているプラグインはv4で利用できるように更新されていますが、コミュニティプラグインの場合v4用にアップデートされていない可能性があるのでご注意ください。

参考

Discussion

ログインするとコメントできます