💧

[Laravel8] Laravel8は動作条件:PHP7.3.0なのに、公式のとおりインストールしただけでは動かなかった話

2022/01/18に公開約500字

アップグレードガイド 8.x Laravel

このページに「動作条件:PHP7.3.0」とあるのにphp7.4のサーバーにアップロードしてブラウザでアクセスすると、

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.0.2". 

上記のエラーが出てきて動きませんでした。

こんなときはcomposerコマンドを使ってパッケージをダウングレードする必要があります。
7.4.12上で動かしたい場合は下記のようにコマンドを実行します。

composer configで、phpのバージョンを指定します。
そしてcomposer upgradeをすると、指定したバージョンにあわせてパッケージのバージョンもダウングレードされます。

composer config platform.php 7.4.12
composer upgrade

上記コマンド実行後ブラウザにアクセスすると、動くことが確認できます。

Discussion

ログインするとコメントできます