😌

ChromeとChromeDriverのバージョン違いによるエラー

1 min read

概要

Seleniumを使ってスクレイピングをしています。
プログラムが動いてない…と思ったらChromeが自動更新されていてCromeDriverとバージョンが合わなくなっていたからだったという話です(つい1時間前までは動いてたのに…)コードはお見せできませんが、備忘録的に記しておきます。

$ python3 sc.py
(中略)
selenium.common.exceptions.SessionNotCreatedException: Message: 
session not created: This version of ChromeDriver only supports Chrome version 84

# バイナリでインストールしたChromeDriver
$ chromedriver --version
ChromeDriver 84.0.4147.30

# 現在のChrome
$ google-chrome --version
Google Chrome 86.0.4240.75

# ChromeDriverのインストール
$ pip install chromedriver-binary==86.0.4240.22
Successfully installed chromedriver-binary-86.0.4240.22.0

今回はChromeDriverをpipでインストールしたので、プログラム(scr.py)に
import chromedriver_binaryを追記

driver = webdriver.Chrome(options=options, executable_path=r'/usr/local/bin/chromedriver')
executable_path以降を削除

参考

Discussion

ログインするとコメントできます