🔖

「digital envelope routines::unsupported」の対処法

2022/11/15に公開約700字

問題

下記プロジェクトでfrontendをnpm install、npm startで始めようとしたところ、上記エラーが発生した。
https://github.com/yxo5017/cd0037-API-Development-and-Documentation-exercises/tree/master/1_Requests_Starter

対処法

下記の通り、バージョンをダウングレードしたところ、エラーが解消された。

  • nodejs: v12.22.12
  • npm : 8.11.0

ダウングレードコマンドは以下の通り

  • npm install -g npm@8.11.0
  • sudo n 12.22.12

参照

https://knowledge.udacity.com/questions/923181
https://zenn.dev/ymasaoka/articles/using-n-for-downgrade-nodejs
https://www.web-dev-qa-db-ja.com/ja/node.js/npmを古いバージョンにダウングレードする/834202879/

Discussion

ログインするとコメントできます