🎅

sonic-vsの初期configを見てみる

2022/12/24に公開約58,200字

sonic-vsの初期configを見てみる

はじめに

これはSONiC Advent Calendar 2022 24日目の記事です。

ホワイトボックス用NetworkOS(NOS)であるSONiCのVM版であるsonic-vsを起動するとIPアドレスなど初期設定が入っています。
今回はこれを確認してみるのと個人的に不要と思う設定の削除をしてみます。

試したSONiCのバージョン

admin@sonic:~$ show version

SONiC Software Version: SONiC.master.174710-c63e9fe59
Distribution: Debian 11.5
Kernel: 5.10.0-18-2-amd64
Build commit: c63e9fe59
Build date: Tue Nov 15 18:24:16 UTC 2022
Built by: AzDevOps@sonic-build-workers-002DZL

Platform: x86_64-kvm_x86_64-r0

SONiCの設定を見てみる

次のコマンドでSONiCの設定を確認できます。

admin@sonic:~$ show runningconfiguration all
admin@sonic:~$ vtysh -c "show running-config"
show runningconfiguration all
{
    "AUTO_TECHSUPPORT": {
        "GLOBAL": {
            "available_mem_threshold": "10.0",
            "max_core_limit": "5.0",
            "max_techsupport_limit": "10.0",
            "min_available_mem": "200",
            "rate_limit_interval": "180",
            "since": "2 days ago",
            "state": "enabled"
        }
    },
    "AUTO_TECHSUPPORT_FEATURE": {
        "bgp": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "database": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "dhcp_relay": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "eventd": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "gbsyncd": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "lldp": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "macsec": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "mgmt-framework": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "mux": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "nat": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "p4rt": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "pmon": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "radv": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "sflow": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "snmp": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "swss": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "syncd": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "teamd": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "telemetry": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        }
    },
    "BGP_DEVICE_GLOBAL": {
        "STATE": {
            "tsa_enabled": "false"
        }
    },
    "BGP_NEIGHBOR": {
        "10.0.0.1": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.0",
            "name": "ARISTA01T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.11": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.10",
            "name": "ARISTA06T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.13": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.12",
            "name": "ARISTA07T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.15": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.14",
            "name": "ARISTA08T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.17": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.16",
            "name": "ARISTA09T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.19": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.18",
            "name": "ARISTA10T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.21": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.20",
            "name": "ARISTA11T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.23": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.22",
            "name": "ARISTA12T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.25": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.24",
            "name": "ARISTA13T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.27": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.26",
            "name": "ARISTA14T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.29": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.28",
            "name": "ARISTA15T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.3": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.2",
            "name": "ARISTA02T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.31": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.30",
            "name": "ARISTA16T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.33": {
            "asn": "64001",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.32",
            "name": "ARISTA01T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.35": {
            "asn": "64002",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.34",
            "name": "ARISTA02T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.37": {
            "asn": "64003",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.36",
            "name": "ARISTA03T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.39": {
            "asn": "64004",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.38",
            "name": "ARISTA04T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.41": {
            "asn": "64005",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.40",
            "name": "ARISTA05T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.43": {
            "asn": "64006",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.42",
            "name": "ARISTA06T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.45": {
            "asn": "64007",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.44",
            "name": "ARISTA07T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.47": {
            "asn": "64008",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.46",
            "name": "ARISTA08T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.49": {
            "asn": "64009",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.48",
            "name": "ARISTA09T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.5": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.4",
            "name": "ARISTA03T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.51": {
            "asn": "64010",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.50",
            "name": "ARISTA10T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.53": {
            "asn": "64011",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.52",
            "name": "ARISTA11T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.55": {
            "asn": "64012",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.54",
            "name": "ARISTA12T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.57": {
            "asn": "64013",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.56",
            "name": "ARISTA13T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.59": {
            "asn": "64014",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.58",
            "name": "ARISTA14T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.61": {
            "asn": "64015",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.60",
            "name": "ARISTA15T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.63": {
            "asn": "64016",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.62",
            "name": "ARISTA16T0",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.7": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.6",
            "name": "ARISTA04T2",
            "nhopself": "0",
            "rrclient": "0"
        },
        "10.0.0.9": {
            "asn": "65200",
            "holdtime": "180",
            "keepalive": "60",
            "local_addr": "10.0.0.8",
            "name": "ARISTA05T2",
            "nhopself": "0",
            "rrclient": "0"
        }
    },
    "CRM": {
        "Config": {
            "acl_counter_high_threshold": "85",
            "acl_counter_low_threshold": "70",
            "acl_counter_threshold_type": "percentage",
            "acl_entry_high_threshold": "85",
            "acl_entry_low_threshold": "70",
            "acl_entry_threshold_type": "percentage",
            "acl_group_high_threshold": "85",
            "acl_group_low_threshold": "70",
            "acl_group_threshold_type": "percentage",
            "acl_table_high_threshold": "85",
            "acl_table_low_threshold": "70",
            "acl_table_threshold_type": "percentage",
            "dnat_entry_high_threshold": "85",
            "dnat_entry_low_threshold": "70",
            "dnat_entry_threshold_type": "percentage",
            "fdb_entry_high_threshold": "85",
            "fdb_entry_low_threshold": "70",
            "fdb_entry_threshold_type": "percentage",
            "ipmc_entry_high_threshold": "85",
            "ipmc_entry_low_threshold": "70",
            "ipmc_entry_threshold_type": "percentage",
            "ipv4_neighbor_high_threshold": "85",
            "ipv4_neighbor_low_threshold": "70",
            "ipv4_neighbor_threshold_type": "percentage",
            "ipv4_nexthop_high_threshold": "85",
            "ipv4_nexthop_low_threshold": "70",
            "ipv4_nexthop_threshold_type": "percentage",
            "ipv4_route_high_threshold": "85",
            "ipv4_route_low_threshold": "70",
            "ipv4_route_threshold_type": "percentage",
            "ipv6_neighbor_high_threshold": "85",
            "ipv6_neighbor_low_threshold": "70",
            "ipv6_neighbor_threshold_type": "percentage",
            "ipv6_nexthop_high_threshold": "85",
            "ipv6_nexthop_low_threshold": "70",
            "ipv6_nexthop_threshold_type": "percentage",
            "ipv6_route_high_threshold": "85",
            "ipv6_route_low_threshold": "70",
            "ipv6_route_threshold_type": "percentage",
            "mpls_inseg_high_threshold": "85",
            "mpls_inseg_low_threshold": "70",
            "mpls_inseg_threshold_type": "percentage",
            "mpls_nexthop_high_threshold": "85",
            "mpls_nexthop_low_threshold": "70",
            "mpls_nexthop_threshold_type": "percentage",
            "nexthop_group_high_threshold": "85",
            "nexthop_group_low_threshold": "70",
            "nexthop_group_member_high_threshold": "85",
            "nexthop_group_member_low_threshold": "70",
            "nexthop_group_member_threshold_type": "percentage",
            "nexthop_group_threshold_type": "percentage",
            "polling_interval": "300",
            "snat_entry_high_threshold": "85",
            "snat_entry_low_threshold": "70",
            "snat_entry_threshold_type": "percentage"
        }
    },
    "DEVICE_METADATA": {
        "localhost": {
            "bgp_asn": "65100",
            "buffer_model": "traditional",
            "default_bgp_status": "up",
            "default_pfcwd_status": "disable",
            "hostname": "sonic",
            "hwsku": "Force10-S6000",
            "mac": "50:00:00:07:00:00",
            "platform": "x86_64-kvm_x86_64-r0",
            "synchronous_mode": "enable",
            "type": "LeafRouter"
        }
    },
    "FEATURE": {
        "bgp": {
            "auto_restart": "enabled",
            "check_up_status": "false",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "database": {
            "auto_restart": "always_enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "always_enabled"
        },
        "dhcp_relay": {
            "auto_restart": "enabled",
            "check_up_status": "False",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "set_owner": "local",
            "state": "disabled"
        },
        "eventd": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "gbsyncd": {
            "auto_restart": "enabled",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "lldp": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "True",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "macsec": {
            "auto_restart": "enabled",
            "check_up_status": "False",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "set_owner": "local",
            "state": "disabled"
        },
        "mgmt-framework": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "mux": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "always_disabled"
        },
        "nat": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "disabled"
        },
        "p4rt": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "disabled"
        },
        "pmon": {
            "auto_restart": "enabled",
            "check_up_status": "false",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "radv": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "sflow": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "disabled"
        },
        "snmp": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "swss": {
            "auto_restart": "enabled",
            "check_up_status": "false",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "syncd": {
            "auto_restart": "enabled",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "teamd": {
            "auto_restart": "enabled",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "telemetry": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        }
    },
    "FLEX_COUNTER_TABLE": {
        "ACL": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "disable",
            "POLL_INTERVAL": "10000"
        },
        "BUFFER_POOL_WATERMARK": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PFCWD": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PG_DROP": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PG_WATERMARK": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PORT": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PORT_BUFFER_DROP": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "QUEUE": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "QUEUE_WATERMARK": {
            "FLEX_COUNTER_STATUS": "enable"
        },
        "RIF": {
            "FLEX_COUNTER_STATUS": "enable"
        }
    },
    "INTERFACE": {
        "Ethernet0": {},
        "Ethernet100": {},
        "Ethernet104": {},
        "Ethernet108": {},
        "Ethernet112": {},
        "Ethernet116": {},
        "Ethernet12": {},
        "Ethernet120": {},
        "Ethernet124": {},
        "Ethernet16": {},
        "Ethernet20": {},
        "Ethernet24": {},
        "Ethernet28": {},
        "Ethernet32": {},
        "Ethernet36": {},
        "Ethernet4": {},
        "Ethernet40": {},
        "Ethernet44": {},
        "Ethernet48": {},
        "Ethernet52": {},
        "Ethernet56": {},
        "Ethernet60": {},
        "Ethernet64": {},
        "Ethernet68": {},
        "Ethernet72": {},
        "Ethernet76": {},
        "Ethernet8": {},
        "Ethernet80": {},
        "Ethernet84": {},
        "Ethernet88": {},
        "Ethernet92": {},
        "Ethernet96": {},
        "Ethernet0|10.0.0.0/31": {},
        "Ethernet100|10.0.0.50/31": {},
        "Ethernet104|10.0.0.52/31": {},
        "Ethernet108|10.0.0.54/31": {},
        "Ethernet112|10.0.0.56/31": {},
        "Ethernet116|10.0.0.58/31": {},
        "Ethernet120|10.0.0.60/31": {},
        "Ethernet124|10.0.0.62/31": {},
        "Ethernet12|10.0.0.6/31": {},
        "Ethernet16|10.0.0.8/31": {},
        "Ethernet20|10.0.0.10/31": {},
        "Ethernet24|10.0.0.12/31": {},
        "Ethernet28|10.0.0.14/31": {},
        "Ethernet32|10.0.0.16/31": {},
        "Ethernet36|10.0.0.18/31": {},
        "Ethernet40|10.0.0.20/31": {},
        "Ethernet44|10.0.0.22/31": {},
        "Ethernet48|10.0.0.24/31": {},
        "Ethernet4|10.0.0.2/31": {},
        "Ethernet52|10.0.0.26/31": {},
        "Ethernet56|10.0.0.28/31": {},
        "Ethernet60|10.0.0.30/31": {},
        "Ethernet64|10.0.0.32/31": {},
        "Ethernet68|10.0.0.34/31": {},
        "Ethernet72|10.0.0.36/31": {},
        "Ethernet76|10.0.0.38/31": {},
        "Ethernet80|10.0.0.40/31": {},
        "Ethernet84|10.0.0.42/31": {},
        "Ethernet88|10.0.0.44/31": {},
        "Ethernet8|10.0.0.4/31": {},
        "Ethernet92|10.0.0.46/31": {},
        "Ethernet96|10.0.0.48/31": {}
    },
    "KDUMP": {
        "config": {
            "enabled": "false",
            "memory": "0M-2G:256M,2G-4G:320M,4G-8G:384M,8G-:448M",
            "num_dumps": "3"
        }
    },
    "LOGGER": {
        "SAI_API_ACL": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_BFD": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_BMTOR": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_BRIDGE": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_BUFFER": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_COUNTER": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_DEBUG_COUNTER": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_DTEL": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_FDB": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_HASH": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_HOSTIF": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_IPMC": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_IPMC_GROUP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_IPSEC": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_ISOLATION_GROUP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_L2MC": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_L2MC_GROUP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_LAG": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_MACSEC": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_MCAST_FDB": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_MIRROR": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_MPLS": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_MY_MAC": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_NAT": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_NEIGHBOR": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_NEXT_HOP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_NEXT_HOP_GROUP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_POLICER": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_PORT": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_QOS_MAP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_QUEUE": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_ROUTE": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_ROUTER_INTERFACE": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_RPF_GROUP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_SAMPLEPACKET": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_SCHEDULER": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_SCHEDULER_GROUP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_SRV6": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_STP": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_SWITCH": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_SYSTEM_PORT": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_TAM": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_TUNNEL": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_UDF": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_VIRTUAL_ROUTER": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_VLAN": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "SAI_API_WRED": {
            "LOGLEVEL": "SAI_LOG_LEVEL_NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "buffermgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "coppmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "fdbsyncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "fpmsyncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "gearsyncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "intfmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "nbrmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "neighsyncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "orchagent": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "portmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "portsyncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "syncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "teammgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "teamsyncd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "tlm_teamd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "tunnelmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "vlanmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "vrfmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        },
        "vxlanmgrd": {
            "LOGLEVEL": "NOTICE",
            "LOGOUTPUT": "SYSLOG"
        }
    },
    "LOOPBACK_INTERFACE": {
        "Loopback0": {},
        "Loopback0|10.1.0.1/32": {}
    },
    "PASSW_HARDENING": {
        "POLICIES": {
            "digits_class": "true",
            "expiration": "180",
            "expiration_warning": "15",
            "history_cnt": "10",
            "len_min": "8",
            "lower_class": "true",
            "reject_user_passw_match": "true",
            "special_class": "true",
            "state": "disabled",
            "upper_class": "true"
        }
    },
    "PORT": {
        "Ethernet0": {
            "admin_status": "up",
            "alias": "fortyGigE0/0",
            "index": "0",
            "lanes": "25,26,27,28",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet100": {
            "admin_status": "up",
            "alias": "fortyGigE0/100",
            "index": "25",
            "lanes": "121,122,123,124",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet104": {
            "admin_status": "up",
            "alias": "fortyGigE0/104",
            "index": "26",
            "lanes": "81,82,83,84",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet108": {
            "admin_status": "up",
            "alias": "fortyGigE0/108",
            "index": "27",
            "lanes": "85,86,87,88",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet112": {
            "admin_status": "up",
            "alias": "fortyGigE0/112",
            "index": "28",
            "lanes": "93,94,95,96",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet116": {
            "admin_status": "up",
            "alias": "fortyGigE0/116",
            "index": "29",
            "lanes": "89,90,91,92",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet12": {
            "admin_status": "up",
            "alias": "fortyGigE0/12",
            "index": "3",
            "lanes": "37,38,39,40",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet120": {
            "admin_status": "up",
            "alias": "fortyGigE0/120",
            "index": "30",
            "lanes": "101,102,103,104",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet124": {
            "admin_status": "up",
            "alias": "fortyGigE0/124",
            "index": "31",
            "lanes": "97,98,99,100",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet16": {
            "admin_status": "up",
            "alias": "fortyGigE0/16",
            "index": "4",
            "lanes": "45,46,47,48",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet20": {
            "admin_status": "up",
            "alias": "fortyGigE0/20",
            "index": "5",
            "lanes": "41,42,43,44",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet24": {
            "admin_status": "up",
            "alias": "fortyGigE0/24",
            "index": "6",
            "lanes": "1,2,3,4",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet28": {
            "admin_status": "up",
            "alias": "fortyGigE0/28",
            "index": "7",
            "lanes": "5,6,7,8",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet32": {
            "admin_status": "up",
            "alias": "fortyGigE0/32",
            "index": "8",
            "lanes": "13,14,15,16",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet36": {
            "admin_status": "up",
            "alias": "fortyGigE0/36",
            "index": "9",
            "lanes": "9,10,11,12",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet4": {
            "admin_status": "up",
            "alias": "fortyGigE0/4",
            "index": "1",
            "lanes": "29,30,31,32",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet40": {
            "admin_status": "up",
            "alias": "fortyGigE0/40",
            "index": "10",
            "lanes": "17,18,19,20",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet44": {
            "admin_status": "up",
            "alias": "fortyGigE0/44",
            "index": "11",
            "lanes": "21,22,23,24",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet48": {
            "admin_status": "up",
            "alias": "fortyGigE0/48",
            "index": "12",
            "lanes": "53,54,55,56",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet52": {
            "admin_status": "up",
            "alias": "fortyGigE0/52",
            "index": "13",
            "lanes": "49,50,51,52",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet56": {
            "admin_status": "up",
            "alias": "fortyGigE0/56",
            "index": "14",
            "lanes": "57,58,59,60",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet60": {
            "admin_status": "up",
            "alias": "fortyGigE0/60",
            "index": "15",
            "lanes": "61,62,63,64",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet64": {
            "admin_status": "up",
            "alias": "fortyGigE0/64",
            "index": "16",
            "lanes": "69,70,71,72",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet68": {
            "admin_status": "up",
            "alias": "fortyGigE0/68",
            "index": "17",
            "lanes": "65,66,67,68",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet72": {
            "admin_status": "up",
            "alias": "fortyGigE0/72",
            "index": "18",
            "lanes": "73,74,75,76",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet76": {
            "admin_status": "up",
            "alias": "fortyGigE0/76",
            "index": "19",
            "lanes": "77,78,79,80",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet8": {
            "admin_status": "up",
            "alias": "fortyGigE0/8",
            "index": "2",
            "lanes": "33,34,35,36",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet80": {
            "admin_status": "up",
            "alias": "fortyGigE0/80",
            "index": "20",
            "lanes": "109,110,111,112",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet84": {
            "admin_status": "up",
            "alias": "fortyGigE0/84",
            "index": "21",
            "lanes": "105,106,107,108",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet88": {
            "admin_status": "up",
            "alias": "fortyGigE0/88",
            "index": "22",
            "lanes": "113,114,115,116",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet92": {
            "admin_status": "up",
            "alias": "fortyGigE0/92",
            "index": "23",
            "lanes": "117,118,119,120",
            "mtu": "9100",
            "speed": "40000"
        },
        "Ethernet96": {
            "admin_status": "up",
            "alias": "fortyGigE0/96",
            "index": "24",
            "lanes": "125,126,127,128",
            "mtu": "9100",
            "speed": "40000"
        }
    },
    "VERSIONS": {
        "DATABASE": {
            "VERSION": "version_4_0_0"
        }
    }
}

まず気になるのは、インターフェースのIPアドレスが設定されてます。

初期IPアドレス
    "INTERFACE": {
        "Ethernet0": {},
        "Ethernet100": {},
        "Ethernet104": {},
        "Ethernet108": {},
        "Ethernet112": {},
        "Ethernet116": {},
        "Ethernet12": {},
        "Ethernet120": {},
        "Ethernet124": {},
        "Ethernet16": {},
        "Ethernet20": {},
        "Ethernet24": {},
        "Ethernet28": {},
        "Ethernet32": {},
        "Ethernet36": {},
        "Ethernet4": {},
        "Ethernet40": {},
        "Ethernet44": {},
        "Ethernet48": {},
        "Ethernet52": {},
        "Ethernet56": {},
        "Ethernet60": {},
        "Ethernet64": {},
        "Ethernet68": {},
        "Ethernet72": {},
        "Ethernet76": {},
        "Ethernet8": {},
        "Ethernet80": {},
        "Ethernet84": {},
        "Ethernet88": {},
        "Ethernet92": {},
        "Ethernet96": {},
        "Ethernet0|10.0.0.0/31": {},
        "Ethernet100|10.0.0.50/31": {},
        "Ethernet104|10.0.0.52/31": {},
        "Ethernet108|10.0.0.54/31": {},
        "Ethernet112|10.0.0.56/31": {},
        "Ethernet116|10.0.0.58/31": {},
        "Ethernet120|10.0.0.60/31": {},
        "Ethernet124|10.0.0.62/31": {},
        "Ethernet12|10.0.0.6/31": {},
        "Ethernet16|10.0.0.8/31": {},
        "Ethernet20|10.0.0.10/31": {},
        "Ethernet24|10.0.0.12/31": {},
        "Ethernet28|10.0.0.14/31": {},
        "Ethernet32|10.0.0.16/31": {},
        "Ethernet36|10.0.0.18/31": {},
        "Ethernet40|10.0.0.20/31": {},
        "Ethernet44|10.0.0.22/31": {},
        "Ethernet48|10.0.0.24/31": {},
        "Ethernet4|10.0.0.2/31": {},
        "Ethernet52|10.0.0.26/31": {},
        "Ethernet56|10.0.0.28/31": {},
        "Ethernet60|10.0.0.30/31": {},
        "Ethernet64|10.0.0.32/31": {},
        "Ethernet68|10.0.0.34/31": {},
        "Ethernet72|10.0.0.36/31": {},
        "Ethernet76|10.0.0.38/31": {},
        "Ethernet80|10.0.0.40/31": {},
        "Ethernet84|10.0.0.42/31": {},
        "Ethernet88|10.0.0.44/31": {},
        "Ethernet8|10.0.0.4/31": {},
        "Ethernet92|10.0.0.46/31": {},
        "Ethernet96|10.0.0.48/31": {}
    },

show ip interfaceからIPが設定していることがわかります。

admin@sonic:~$ show ip interfaces
Interface    Master    IPv4 address/mask    Admin/Oper    BGP Neighbor    Neighbor IP
-----------  --------  -------------------  ------------  --------------  -------------
Ethernet0              10.0.0.0/31          up/up         ARISTA01T2      10.0.0.1
Ethernet4              10.0.0.2/31          up/up         ARISTA02T2      10.0.0.3
Ethernet8              10.0.0.4/31          up/up         ARISTA03T2      10.0.0.5
Ethernet12             10.0.0.6/31          up/up         ARISTA04T2      10.0.0.7
Ethernet16             10.0.0.8/31          up/up         ARISTA05T2      10.0.0.9
Ethernet20             10.0.0.10/31         up/up         ARISTA06T2      10.0.0.11
Ethernet24             10.0.0.12/31         up/up         ARISTA07T2      10.0.0.13
Ethernet28             10.0.0.14/31         up/up         ARISTA08T2      10.0.0.15
Ethernet32             10.0.0.16/31         up/up         ARISTA09T2      10.0.0.17
Ethernet36             10.0.0.18/31         up/up         ARISTA10T2      10.0.0.19
Ethernet40             10.0.0.20/31         up/up         ARISTA11T2      10.0.0.21
Ethernet44             10.0.0.22/31         up/up         ARISTA12T2      10.0.0.23
Ethernet48             10.0.0.24/31         up/up         ARISTA13T2      10.0.0.25
Ethernet52             10.0.0.26/31         up/up         ARISTA14T2      10.0.0.27
Ethernet56             10.0.0.28/31         up/up         ARISTA15T2      10.0.0.29
Ethernet60             10.0.0.30/31         up/up         ARISTA16T2      10.0.0.31
Ethernet64             10.0.0.32/31         up/up         ARISTA01T0      10.0.0.33
Ethernet68             10.0.0.34/31         up/up         ARISTA02T0      10.0.0.35
Ethernet72             10.0.0.36/31         up/up         ARISTA03T0      10.0.0.37
Ethernet76             10.0.0.38/31         up/up         ARISTA04T0      10.0.0.39
Ethernet80             10.0.0.40/31         up/up         ARISTA05T0      10.0.0.41
Ethernet84             10.0.0.42/31         up/up         ARISTA06T0      10.0.0.43
Ethernet88             10.0.0.44/31         up/up         ARISTA07T0      10.0.0.45
Ethernet92             10.0.0.46/31         up/up         ARISTA08T0      10.0.0.47
Ethernet96             10.0.0.48/31         up/up         ARISTA09T0      10.0.0.49
Ethernet100            10.0.0.50/31         up/up         ARISTA10T0      10.0.0.51
Ethernet104            10.0.0.52/31         up/up         ARISTA11T0      10.0.0.53
Ethernet108            10.0.0.54/31         up/up         ARISTA12T0      10.0.0.55
Ethernet112            10.0.0.56/31         up/up         ARISTA13T0      10.0.0.57
Ethernet116            10.0.0.58/31         up/up         ARISTA14T0      10.0.0.59
Ethernet120            10.0.0.60/31         up/up         ARISTA15T0      10.0.0.61
Ethernet124            10.0.0.62/31         up/up         ARISTA16T0      10.0.0.63
Loopback0              10.1.0.1/32          up/up         N/A             N/A
docker0                240.127.1.1/24       up/down       N/A             N/A
lo                     127.0.0.1/16         up/up         N/A             N/A

次に気になるのがBGPの設定がされています。
実際にFRRの設定を確認すると設定が入っています。

vtysh -c "show running-config"
admin@sonic:~$ vtysh -c "show running-config"
Building configuration...

Current configuration:
!
frr version 8.2.2
frr defaults traditional
hostname sonic
log syslog informational
log facility local4
agentx
no service integrated-vtysh-config
!
password zebra
enable password zebra
!
router bgp 65100
 bgp router-id 10.1.0.1
 bgp log-neighbor-changes
 no bgp ebgp-requires-policy
 no bgp default ipv4-unicast
 bgp bestpath as-path multipath-relax
 neighbor PEER_V4 peer-group
 neighbor PEER_V6 peer-group
 neighbor 10.0.0.1 remote-as 65200
 neighbor 10.0.0.1 peer-group PEER_V4
 neighbor 10.0.0.1 description ARISTA01T2
 neighbor 10.0.0.1 timers connect 10
 neighbor 10.0.0.3 remote-as 65200
 neighbor 10.0.0.3 peer-group PEER_V4
 neighbor 10.0.0.3 description ARISTA02T2
 neighbor 10.0.0.3 timers connect 10
 neighbor 10.0.0.5 remote-as 65200
 neighbor 10.0.0.5 peer-group PEER_V4
 neighbor 10.0.0.5 description ARISTA03T2
 neighbor 10.0.0.5 timers connect 10
 neighbor 10.0.0.7 remote-as 65200
 neighbor 10.0.0.7 peer-group PEER_V4
 neighbor 10.0.0.7 description ARISTA04T2
 neighbor 10.0.0.7 timers connect 10
 neighbor 10.0.0.9 remote-as 65200
 neighbor 10.0.0.9 peer-group PEER_V4
 neighbor 10.0.0.9 description ARISTA05T2
 neighbor 10.0.0.9 timers connect 10
 neighbor 10.0.0.11 remote-as 65200
 neighbor 10.0.0.11 peer-group PEER_V4
 neighbor 10.0.0.11 description ARISTA06T2
 neighbor 10.0.0.11 timers connect 10
 neighbor 10.0.0.13 remote-as 65200
 neighbor 10.0.0.13 peer-group PEER_V4
 neighbor 10.0.0.13 description ARISTA07T2
 neighbor 10.0.0.13 timers connect 10
 neighbor 10.0.0.15 remote-as 65200
 neighbor 10.0.0.15 peer-group PEER_V4
 neighbor 10.0.0.15 description ARISTA08T2
 neighbor 10.0.0.15 timers connect 10
 neighbor 10.0.0.17 remote-as 65200
 neighbor 10.0.0.17 peer-group PEER_V4
 neighbor 10.0.0.17 description ARISTA09T2
 neighbor 10.0.0.17 timers connect 10
 neighbor 10.0.0.19 remote-as 65200
 neighbor 10.0.0.19 peer-group PEER_V4
 neighbor 10.0.0.19 description ARISTA10T2
 neighbor 10.0.0.19 timers connect 10
 neighbor 10.0.0.21 remote-as 65200
 neighbor 10.0.0.21 peer-group PEER_V4
 neighbor 10.0.0.21 description ARISTA11T2
 neighbor 10.0.0.21 timers connect 10
 neighbor 10.0.0.23 remote-as 65200
 neighbor 10.0.0.23 peer-group PEER_V4
 neighbor 10.0.0.23 description ARISTA12T2
 neighbor 10.0.0.23 timers connect 10
 neighbor 10.0.0.25 remote-as 65200
 neighbor 10.0.0.25 peer-group PEER_V4
 neighbor 10.0.0.25 description ARISTA13T2
 neighbor 10.0.0.25 timers connect 10
 neighbor 10.0.0.27 remote-as 65200
 neighbor 10.0.0.27 peer-group PEER_V4
 neighbor 10.0.0.27 description ARISTA14T2
 neighbor 10.0.0.27 timers connect 10
 neighbor 10.0.0.29 remote-as 65200
 neighbor 10.0.0.29 peer-group PEER_V4
 neighbor 10.0.0.29 description ARISTA15T2
 neighbor 10.0.0.29 timers connect 10
 neighbor 10.0.0.31 remote-as 65200
 neighbor 10.0.0.31 peer-group PEER_V4
 neighbor 10.0.0.31 description ARISTA16T2
 neighbor 10.0.0.31 timers connect 10
 neighbor 10.0.0.33 remote-as 64001
 neighbor 10.0.0.33 peer-group PEER_V4
 neighbor 10.0.0.33 description ARISTA01T0
 neighbor 10.0.0.33 timers connect 10
 neighbor 10.0.0.35 remote-as 64002
 neighbor 10.0.0.35 peer-group PEER_V4
 neighbor 10.0.0.35 description ARISTA02T0
 neighbor 10.0.0.35 timers connect 10
 neighbor 10.0.0.37 remote-as 64003
 neighbor 10.0.0.37 peer-group PEER_V4
 neighbor 10.0.0.37 description ARISTA03T0
 neighbor 10.0.0.37 timers connect 10
 neighbor 10.0.0.39 remote-as 64004
 neighbor 10.0.0.39 peer-group PEER_V4
 neighbor 10.0.0.39 description ARISTA04T0
 neighbor 10.0.0.39 timers connect 10
 neighbor 10.0.0.41 remote-as 64005
 neighbor 10.0.0.41 peer-group PEER_V4
 neighbor 10.0.0.41 description ARISTA05T0
 neighbor 10.0.0.41 timers connect 10
 neighbor 10.0.0.43 remote-as 64006
 neighbor 10.0.0.43 peer-group PEER_V4
 neighbor 10.0.0.43 description ARISTA06T0
 neighbor 10.0.0.43 timers connect 10
 neighbor 10.0.0.45 remote-as 64007
 neighbor 10.0.0.45 peer-group PEER_V4
 neighbor 10.0.0.45 description ARISTA07T0
 neighbor 10.0.0.45 timers connect 10
 neighbor 10.0.0.47 remote-as 64008
 neighbor 10.0.0.47 peer-group PEER_V4
 neighbor 10.0.0.47 description ARISTA08T0
 neighbor 10.0.0.47 timers connect 10
 neighbor 10.0.0.49 remote-as 64009
 neighbor 10.0.0.49 peer-group PEER_V4
 neighbor 10.0.0.49 description ARISTA09T0
 neighbor 10.0.0.49 timers connect 10
 neighbor 10.0.0.51 remote-as 64010
 neighbor 10.0.0.51 peer-group PEER_V4
 neighbor 10.0.0.51 description ARISTA10T0
 neighbor 10.0.0.51 timers connect 10
 neighbor 10.0.0.53 remote-as 64011
 neighbor 10.0.0.53 peer-group PEER_V4
 neighbor 10.0.0.53 description ARISTA11T0
 neighbor 10.0.0.53 timers connect 10
 neighbor 10.0.0.55 remote-as 64012
 neighbor 10.0.0.55 peer-group PEER_V4
 neighbor 10.0.0.55 description ARISTA12T0
 neighbor 10.0.0.55 timers connect 10
 neighbor 10.0.0.57 remote-as 64013
 neighbor 10.0.0.57 peer-group PEER_V4
 neighbor 10.0.0.57 description ARISTA13T0
 neighbor 10.0.0.57 timers connect 10
 neighbor 10.0.0.59 remote-as 64014
 neighbor 10.0.0.59 peer-group PEER_V4
 neighbor 10.0.0.59 description ARISTA14T0
 neighbor 10.0.0.59 timers connect 10
 neighbor 10.0.0.61 remote-as 64015
 neighbor 10.0.0.61 peer-group PEER_V4
 neighbor 10.0.0.61 description ARISTA15T0
 neighbor 10.0.0.61 timers connect 10
 neighbor 10.0.0.63 remote-as 64016
 neighbor 10.0.0.63 peer-group PEER_V4
 neighbor 10.0.0.63 description ARISTA16T0
 neighbor 10.0.0.63 timers connect 10
 !
 address-family ipv4 unicast
  network 10.1.0.1/32
  neighbor PEER_V4 soft-reconfiguration inbound
  neighbor PEER_V4 route-map FROM_BGP_PEER_V4 in
  neighbor PEER_V4 route-map TO_BGP_PEER_V4 out
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.5 activate
  neighbor 10.0.0.7 activate
  neighbor 10.0.0.9 activate
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.13 activate
  neighbor 10.0.0.15 activate
  neighbor 10.0.0.17 activate
  neighbor 10.0.0.19 activate
  neighbor 10.0.0.21 activate
  neighbor 10.0.0.23 activate
  neighbor 10.0.0.25 activate
  neighbor 10.0.0.27 activate
  neighbor 10.0.0.29 activate
  neighbor 10.0.0.31 activate
  neighbor 10.0.0.33 activate
  neighbor 10.0.0.35 activate
  neighbor 10.0.0.37 activate
  neighbor 10.0.0.39 activate
  neighbor 10.0.0.41 activate
  neighbor 10.0.0.43 activate
  neighbor 10.0.0.45 activate
  neighbor 10.0.0.47 activate
  neighbor 10.0.0.49 activate
  neighbor 10.0.0.51 activate
  neighbor 10.0.0.53 activate
  neighbor 10.0.0.55 activate
  neighbor 10.0.0.57 activate
  neighbor 10.0.0.59 activate
  neighbor 10.0.0.61 activate
  neighbor 10.0.0.63 activate
  maximum-paths 64
 exit-address-family
 !
 address-family ipv6 unicast
  neighbor PEER_V6 soft-reconfiguration inbound
  neighbor PEER_V6 route-map FROM_BGP_PEER_V6 in
  neighbor PEER_V6 route-map TO_BGP_PEER_V6 out
  maximum-paths 64
 exit-address-family
exit
!
ip prefix-list PL_LoopbackV4 seq 5 permit 10.1.0.1/32
!
bgp community-list standard allow_list_default_community seq 5 permit no-export
bgp community-list standard allow_list_default_community seq 10 permit 5060:12345
!
route-map ALLOW_LIST_DEPLOYMENT_ID_0_V4 permit 65535
 set community 5060:12345 additive
exit
!
route-map ALLOW_LIST_DEPLOYMENT_ID_0_V6 permit 65535
 set community 5060:12345 additive
exit
!
route-map FROM_BGP_PEER_V4 permit 10
 call ALLOW_LIST_DEPLOYMENT_ID_0_V4
 on-match next
exit
!
route-map FROM_BGP_PEER_V4 permit 11
 match community allow_list_default_community
exit
!
route-map FROM_BGP_PEER_V4 permit 100
exit
!
route-map FROM_BGP_PEER_V6 permit 1
 on-match next
 set ipv6 next-hop prefer-global
exit
!
route-map FROM_BGP_PEER_V6 permit 10
 call ALLOW_LIST_DEPLOYMENT_ID_0_V6
 on-match next
exit
!
route-map FROM_BGP_PEER_V6 permit 11
 match community allow_list_default_community
exit
!
route-map FROM_BGP_PEER_V6 permit 100
exit
!
route-map TO_BGP_PEER_V4 permit 100
exit
!
route-map TO_BGP_PEER_V6 permit 100
exit
!
route-map RM_SET_SRC permit 10
 set src 10.1.0.1
exit
!
ip nht resolve-via-default
!
ip protocol bgp route-map RM_SET_SRC
!
end
admin@

FRRの設定をvtysh -c "sh run"で確認しても設定が入っていることがわかります。

不要な設定を削除しよう

SONiCの設定で簡単なのはCLI経由で削除コマンドを直接叩く方法かconfig_db.jsonやbgpdを直接編集して読み込ませる方法があります。
(SONiCへの設定はSONiC CLIとRESTCONFもありますが今回は割愛します。)

IPアドレスを削除する

IPアドレスの削除には次のコマンドを使います。

admin@sonic:~$ config interface ip remove <interface_name> <ip_addr>

このコマンドで初期IPを削除するには、こうなります。
(コピペで使いやすいようにadmin@sonic:~$ を消してます)

sudo config int ip remove Ethernet0 10.0.0.0/31
sudo config int ip remove Ethernet4 10.0.0.2/31
sudo config int ip remove Ethernet8 10.0.0.4/31
sudo config int ip remove Ethernet12 10.0.0.6/31
sudo config int ip remove Ethernet16 10.0.0.8/31
sudo config int ip remove Ethernet20 10.0.0.10/31
sudo config int ip remove Ethernet24 10.0.0.12/31
sudo config int ip remove Ethernet28 10.0.0.14/31
sudo config int ip remove Ethernet32 10.0.0.16/31
sudo config int ip remove Ethernet36 10.0.0.18/31
sudo config int ip remove Ethernet40 10.0.0.20/31
sudo config int ip remove Ethernet44 10.0.0.22/31
sudo config int ip remove Ethernet48 10.0.0.24/31
sudo config int ip remove Ethernet52 10.0.0.26/31
sudo config int ip remove Ethernet56 10.0.0.28/31
sudo config int ip remove Ethernet60 10.0.0.30/31
sudo config int ip remove Ethernet64 10.0.0.32/31
sudo config int ip remove Ethernet68 10.0.0.34/31
sudo config int ip remove Ethernet72 10.0.0.36/31
sudo config int ip remove Ethernet76 10.0.0.38/31
sudo config int ip remove Ethernet80 10.0.0.40/31
sudo config int ip remove Ethernet84 10.0.0.42/31
sudo config int ip remove Ethernet88 10.0.0.44/31
sudo config int ip remove Ethernet92 10.0.0.46/31
sudo config int ip remove Ethernet96 10.0.0.48/31
sudo config int ip remove Ethernet100 10.0.0.50/31
sudo config int ip remove Ethernet104 10.0.0.52/31
sudo config int ip remove Ethernet108 10.0.0.54/31
sudo config int ip remove Ethernet112 10.0.0.56/31
sudo config int ip remove Ethernet116 10.0.0.58/31
sudo config int ip remove Ethernet120 10.0.0.60/31
sudo config int ip remove Ethernet124 10.0.0.62/31
sudo config int ip remove Loopback0 10.1.0.1/32
sudo config save -y
sudo config reload -y -f

また、config_db.jsonから削除するにはこのコマンドで削除できます。

admin@sonic:~$ sudo cat /etc/sonic/config_db.json | jq 'del(.INTERFACE)' | sudo tee /etc/sonic/config_db.json
admin@sonic:~$ sudo config reload -y -f

しかし、この方法では設定しているIPアドレスを全て削除することになります。

上記のCLIかDBからIPアドレスを削除した結果、show ip interfaceでIPアドレスが削除していることがわかります。

admin@sonic:~$ show ip interfaces
Interface    Master    IPv4 address/mask    Admin/Oper    BGP Neighbor    Neighbor IP
-----------  --------  -------------------  ------------  --------------  -------------
Loopback0              10.1.0.1/32          up/up         N/A             N/A
docker0                240.127.1.1/24       up/down       N/A             N/A
lo                     127.0.0.1/16         up/up         N/A             N/A

ちなみにIPを追加するコマンドはこのようになります。

admin@sonic:~$ config interface ip add <interface_name> <ip_addr>

BGP設定を削除する

BGP設定はFRRのvtyshから行います。
このコマンドで削除ができます。

admin@sonic:~$ vtysh -c "conf t" \
                     -c "no router bgp 65100" \
                     -c "no ip prefix-list PL_LoopbackV4 seq 5 permit 10.1.0.1/32" \
                     -c "no bgp community-list standard allow_list_default_community seq 5 permit no-export" \
                     -c "no bgp community-list standard allow_list_default_community seq 10 permit 5060:12345" \
                     -c "no route-map ALLOW_LIST_DEPLOYMENT_ID_0_V4 permit 65535" \
                     -c "no route-map ALLOW_LIST_DEPLOYMENT_ID_0_V6 permit 65535" \
                     -c "no route-map FROM_BGP_PEER_V4 permit 10" \
                     -c "no route-map FROM_BGP_PEER_V4 permit 11" \
                     -c "no route-map FROM_BGP_PEER_V4 permit 100" \
                     -c "no route-map FROM_BGP_PEER_V6 permit 1" \
                     -c "no route-map FROM_BGP_PEER_V6 permit 10" \
                     -c "no route-map FROM_BGP_PEER_V6 permit 11" \
                     -c "no route-map FROM_BGP_PEER_V6 permit 100" \
                     -c "no route-map TO_BGP_PEER_V4 permit 100" \
                     -c "no route-map TO_BGP_PEER_V6 permit 100" \
                     -c "no route-map RM_SET_SRC permit 10" \
                     -c "no ip nht resolve-via-default" \
                     -c "no ip protocol bgp route-map RM_SET_SRC" \
                     -c "exit" \
                     -c "write"

設定が削除したことの確認をします。

admin@sonic:~$ vtysh -c "show running-config"
Building configuration...

Current configuration:
!
frr version 8.2.2
frr defaults traditional
hostname sonic
log syslog informational
log facility local4
agentx
no service integrated-vtysh-config
!
password zebra
enable password zebra
!
end

しかし、SONiCのconfig_db.jsonのDEVICE_METADATAにはBGPの記載があります。
これがきになるでsedで消します。

admin@sonic:~$ sudo sed -i '/"bgp_asn": "65100",/d' /etc/sonic/config_db.json
admin@sonic:~$ sudo config reload -y 

これでBGPの設定は削除できました。

## あとがき
今回はsonic-vsの初期設定の確認と個人的に不要な設定の削除を行いました。
次はSONiCをビルドするときに生成される初期設定のconfig_db.jsonから上記のIPアドレスやBGP設定を削除したいです。
(次回は未定)

Discussion

ログインするとコメントできます