🌟

[M1Mac]Androidの古いOSエミュレータが起動しない問題

2022/04/03に公開約800字

問題

M1 MacでAndroid9系や11,12のOS versionエミュレータは問題なく起動するのに
Android7.0や7.1.1のような古いものだと起動しない。(Imageは arm64-v8a を選択している)

現象

このまま待ち続けてもTimeout tool windowをOFFにしてスタンドアローンにしても真っ暗なままで起動しない

解消(?)

ググるとよくあるエミュレータを作成し直す、 Wipe Dataしてみる、Graphics:AutomaticからHardwareに変えてみる等では解消しなかった。

さらにググったら一応の解決法があった。
ここのコメントの通り、Android Emulatorをcanary31.3.3 以上にアップデートすると無事Android7系でも起動するようになった。

2022/4/3時点では31.3.5


上記コメントにある通り重いが起動はした

Discussion

ログインするとコメントできます