🇫🇷

フレームリレーの練習

2023/01/14に公開約32,300字

本エントリについて

Dynagen、Dynamips を使って、フレームリレーを練習します。
Dynagen、Dynamips の利用環境はすでに整っているものとします。

参考

http://jukenki.com/contents/cisco/ccna-lab-scenario/lab4-framerelay-hub-and-spoke.html

基本設定

    [[ROUTER r1]]
        model = 3725
        console = 2001
        f0/0 = NIO_tap:tap0
        #s1/0 = r2 s1/1
        s1/0 = FR1 1
    [[ROUTER r2]]
        model = 3725
        console = 2002
        f0/0 = NIO_udp:30000:127.0.0.1:20000
        #s1/0 = r3 s1/1
        s1/0 = FR1 2
    [[FRSW FR1]]
        1:102 = 2:201
r1(config)#int s1/0
r1(config-if)#ip address 172.16.0.1 255.255.255.0
r1(config-if)#encapsulation frame-relay
r1(config-if)#frame-relay map ip 172.16.0.2 102 broadcast
r1(config-if)#no shut
r2(config)#interface Serial1/0
r2(config-if)#ip address 172.16.0.2 255.255.255.0
r2(config-if)#encapsulation frame-relay
r2(config-if)#frame-relay map ip 172.16.0.1 201 broadcast
r2(config-if)#no shut

疎通確認を実施して、インタフェースの状態を確認します。

r2#ping 172.16.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/28 ms

r2#show int s1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.0.2/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  LMI enq sent  3, LMI stat recvd 4, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE  segmentation inactive
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 00:00:41
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5 packets input, 75 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     7 packets output, 96 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

フレームリレーの状態を確認します。

r2#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 11               Num Status msgs Rcvd 12
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:52         Last Full Status Rcvd 00:00:51

r2#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 5             output pkts 5            in bytes 520
  out bytes 520            dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:12, last time pvc status changed 00:01:08

r2#show frame-relay map
Serial1/0 (up): ip 172.16.0.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active

r1でフレームリレーの状態を確認します。

r1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 32               Num Status msgs Rcvd 33
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:22         Last Full Status Rcvd 00:00:22

r1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 5             output pkts 5            in bytes 520
  out bytes 520            dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:05:31, last time pvc status changed 00:04:26

r1#show frame-relay map
Serial1/0 (up): ip 172.16.0.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

インタフェースの状態を確認します。

r1#show int s1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.0.1/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  LMI enq sent  28, LMI stat recvd 29, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE  segmentation inactive
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:09, output 00:00:09, output hang never
  Last clearing of "show interface" counters 00:04:58
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     35 packets input, 965 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     37 packets output, 966 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

r1#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  172.16.0.1      YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Loopback0                  1.1.1.1         YES manual up                    up

OSPF に寄り道

ここで OSPF を有効化します。

r1(config)#router ospf 1
r1(config-router)#network 172.16.0.1 0.0.0.255 area 0
r1(config-router)#network 1.1.1.1 0.0.0.0 area 0

状態を確認します。
OSPFのインタフェースでタイプが NON_BROADCAST になっています。
このとき、ピアは手動で設定する必要があります。

r1#show ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 172.16.0.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 172.16.0.1
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:11
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

ピアルータを指定します。

r1(config)#router ospf 1
r1(config-router)#neighbor 172.16.0.2
r2#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  172.16.0.2      YES manual up                    up
Serial1/1                  unassigned      YES unset  administratively down down
Serial1/2                  unassigned      YES unset  administratively down down
Serial1/3                  unassigned      YES unset  administratively down down
Loopback0                  2.2.2.2         YES manual up                    up

r2 でも OSPF を有効化します。

r2(config)#router ospf 1
r2(config-router)#network 172.16.0.0 0.0.0.255 area 0
r2(config-router)#network 2.2.2.2 0.0.0.0 area 0
r2(config-router)#neighbor 172.16.0.1

状態を確認します。
DRが選出されてアジャセンシが確立しています。自分がDRとなっています。

r2#show ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 172.16.0.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 172.16.0.2
  Backup Designated router (ID) 1.1.1.1, Interface address 172.16.0.1
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

r2#show ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:01:51    172.16.0.1      Serial1/0

r2#show ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         195         0x80000003 0x000652 2
2.2.2.2         2.2.2.2         194         0x80000003 0x00F555 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.0.2      2.2.2.2         194         0x80000001 0x004027

r2#show ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 172.16.0.1, 00:03:19, Serial1/0

r1 で状態を確認します。

r1#show ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:01:37    172.16.0.2      Serial1/0

r1#show ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         257         0x80000003 0x000652 2
2.2.2.2         2.2.2.2         258         0x80000003 0x00F555 2

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.0.2      2.2.2.2         258         0x80000001 0x004027

r1#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.0.2, 00:04:20, Serial1/0

ハブアンドスポーク

    [[ROUTER r1]]
        model = 3725
        console = 2001
        f0/0 = NIO_tap:tap0
        #s1/0 = r2 s1/1
        s1/0 = FR1 1
    [[ROUTER r2]]
        model = 3725
        console = 2002
        f0/0 = NIO_udp:30000:127.0.0.1:20000
        #s1/0 = r3 s1/1
        s1/0 = FR1 2
    [[ROUTER r3]]
        model = 3725
        console = 2003
        f0/0 = NIO_udp:30001:127.0.0.1:20001
        s1/0 = FR1 3
    [[FRSW FR1]]
        1:102 = 2:201
        1:103 = 3:301

ハブルータとなる r1 で設定します。

r1(config)#int s1/0
r1(config-if)#ip address 172.16.0.1 255.255.255.0
r1(config-if)#encapsulation frame-relay
r1(config-if)#frame-relay map ip 172.16.0.2 102 broadcast
r1(config-if)#no shut

スポークとなる r2で設定します。

r2(config)#int s1/0
r2(config-if)#ip address 172.16.0.2 255.255.255.0
r2(config-if)#encapsulation frame-relay
r2(config-if)#frame-relay map ip 172.16.0.1 201 broadcast
r2(config-if)#no shut

疎通を確認します。

r2#ping 172.16.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/24 ms

同じく、スポークとなる r3で設定します。

r3(config)#int s1/0
r3(config-if)#ip address 172.16.0.3 255.255.255.0
r3(config-if)#encapsulation frame-relay
r3(config-if)#frame-relay map ip 172.16.0.1 301 broadcast
r3(config-if)#no shut

r1 との疎通を確認します。

r3#ping 172.16.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/21/40 ms

r3#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 14               Num Status msgs Rcvd 15
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:29         Last Full Status Rcvd 00:00:29

r3#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 11            output pkts 17           in bytes 1074
  out bytes 1768           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:39, last time pvc status changed 00:01:35

r3#show frame-relay map
Serial1/0 (up): ip 172.16.0.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active

r1 でマッピングの状況を確認します。

r1#show frame-relay map
Serial1/0 (up): ip 172.16.0.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.0.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,, status defined, active

r3 でマッピングの設定を追加します。

r3(config)#int s1/0
r3(config-if)#frame-relay map ip 172.16.0.2 301 broadcast

r3#show frame-relay map
Serial1/0 (up): ip 172.16.0.2 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.0.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active

r2 でもマッピングの設定を追加します。

r2(config)#int s1/0
r2(config-if)#frame-relay map ip 172.16.0.3 201 broadcast

r2#show frame-relay map
Serial1/0 (up): ip 172.16.0.3 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.0.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active

r2 とr3 の間で疎通を確認します。

r2#ping 172.16.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/33/40 ms
r3#ping 172.16.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/44 ms

マルチポイント・サブインターフェイス

マルチポイント・サブインタフェースを使って設定してみます。

ハブルートとなる r1 で元の設定を削除したあと、マルチポイント・サブインタフェースを使う設定を追加します。

r1(config)#int s1/0
r1(config-if)#shut
r1(config-if)#no frame-relay map ip 172.16.0.2 102
r1(config-if)#no ip addr
r1(config-if)#encapsulation frame-relay
r1(config)#int s1/0.1 multipoint
r1(config-subif)#ip addr 172.16.0.1 255.255.255.0
r1(config-subif)#frame-relay map ip 172.16.0.2 102
r1(config-subif)#frame-relay map ip 172.16.0.3 103
r1(config-subif)#no shut

r1(config)#int s1/0
r1(config-if)#no shut

r1#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial1/0                  unassigned      YES manual up                    up
Serial1/0.1                172.16.0.1      YES manual up                    up
Serial1/1                  unassigned      YES NVRAM  administratively down down
Serial1/2                  unassigned      YES NVRAM  administratively down down
Serial1/3                  unassigned      YES NVRAM  administratively down down
Loopback0                  1.1.1.1         YES NVRAM  up                    up
r1#show int s1/0.1
Serial1/0.1 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.0.1/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY
  CRC checking enabled
  Last clearing of "show interface" counters never

状態を確認します。

r1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 126              Num Status msgs Rcvd 128
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:02         Last Full Status Rcvd 00:00:02

r1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:52, last time pvc status changed 00:01:06

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:02:37, last time pvc status changed 00:01:08

r1#show frame-relay map
Serial1/0.1 (up): ip 172.16.0.2 dlci 102(0x66,0x1860), static,
              CISCO, status defined, active
Serial1/0.1 (up): ip 172.16.0.3 dlci 103(0x67,0x1870), static,
              CISCO, status defined, active

r2、r3に対して、疎通を確認します。

r1#ping 172.16.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms

r1#ping 172.16.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

r2 から r3に対して疎通を確認します。

r2#ping 172.16.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/40 ms

ポイントトゥポイント・サブインタフェース

ポイントトゥポイント・サブインタフェースを使って設定してみます。

スポークルータとなる r2 で設定を変更します。

r2(config)#int s1/0
r2(config-if)#ip address 172.16.0.2 255.255.255.0
r2(config-if)#encapsulation frame-relay
r2(config-if)#frame-relay map ip 172.16.1.1 201 broadcast
r2(config-if)#no shut

同じくスポークルータとなる r3 で設定を変更します。

r3(config)#int s1/0
r3(config-if)#ip address 172.16.1.2 255.255.255.0
r3(config-if)#encapsulation frame-relay
r3(config-if)#frame-relay map ip 172.16.1.1 301 broadcast
r3(config-if)#no shut

ハブルータとなる r1 で元の設定を削除し、ポイントトゥポイント・サブインタフェースを利用する設定を追加します。
このとき、 frame-relay map は利用できません。 frame-relay interface-dlci を指定します。

r1(config)#int s1/0
r1(config-if)#no ip addr
r1(config-if)#encapsulation frame-relay
r1(config)#int s1/0.1 point-to-point
r1(config-subif)#frame-relay map ip 172.16.0.2 102 broadcast
r1(config-subif)#frame-relay interface-dlci 102
r1(config-fr-dlci)#int s1/0.2 point-to-point
r1(config-subif)#ip addr 172.16.1.1 255.255.255.0
r1(config-subif)#frame-relay interface-dlci 103
r1(config-fr-dlci)#int s1/0
r1(config-if)#no shut

疎通を確認します。

r1#ping 172.16.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/52 ms

r1#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/23/36 ms

状態を確認します。

r1#show ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Serial1/0                  unassigned      YES manual up                    up
Serial1/0.1                172.16.0.1      YES manual up                    up
Serial1/0.2                172.16.1.1      YES manual up                    up
Serial1/1                  unassigned      YES NVRAM  administratively down down
Serial1/2                  unassigned      YES NVRAM  administratively down down
Serial1/3                  unassigned      YES NVRAM  administratively down down
Loopback0                  1.1.1.1         YES NVRAM  up                    up

r1#show int s1/0.1
Serial1/0.1 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.0.1/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY
  CRC checking enabled
  Last clearing of "show interface" counters never

r1#show int s1/0.2
Serial1/0.2 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.1.1/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY
  CRC checking enabled
  Last clearing of "show interface" counters never
r1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 16               Num Status msgs Rcvd 17
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:46         Last Full Status Rcvd 00:00:46

r1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          2            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.1

  input pkts 5             output pkts 7            in bytes 520
  out bytes 1198           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 2         out bcast bytes 678
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:04:21, last time pvc status changed 00:01:51

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0.2

  input pkts 5             output pkts 7            in bytes 520
  out bytes 1198           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 2         out bcast bytes 678
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:03:14, last time pvc status changed 00:01:53

r1#show frame-relay map
Serial1/0.1 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
          status defined, active
Serial1/0.2 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast
          status defined, active

OSPF に寄り道

ここで r1 で OSPF を有効化します。

r1(config)#router ospf 1
r1(config-router)#network 172.16.0.0 0.0.0.255 area 0
r1(config-router)#network 172.16.1.0 0.0.0.255 area 0

状態を確認します。
OSPFインタフェースを確認すると、タイプが POINT_TO_POINT となっています。

r1#show ip ospf int
Serial1/0.2 is up, line protocol is up
  Internet Address 172.16.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
Serial1/0.1 is up, line protocol is up
  Internet Address 172.16.0.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

r2 でも OSPF を有効化します。

r2(config)#router ospf 1
r2(config-router)#network 172.16.0.0 0.0.0.255 area 0

OSPFインタフェースを確認すると、タイプが NON_BROADCAST となっています。
この状態だとアジャセンシが確立しません。

r2#show ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 172.16.0.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State WAITING, Priority 1
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:21
    Wait time before Designated router selection 00:01:25
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

r2 のOSPFインタフェースのネットワークタイプを変更してみます。

r2(config)#int s1/0
r2(config-if)#ip ospf network point-to-point

状態を確認します。

r2#show ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:00:33    172.16.0.1      Serial1/0

r2#show ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         37          0x80000003 0x00EC1D 3
2.2.2.2         2.2.2.2         36          0x80000002 0x0028EB 2

r2#show ip route ospf
     172.16.0.0/24 is subnetted, 2 subnets
O       172.16.1.0 [110/128] via 172.16.0.1, 00:01:02, Serial1/0

r3でもOSPFを有効にします。
同じように、インタフェースのネットワークタイプを point-to-point に変更します。

r3(config)#router ospf 1
r3(config-router)#network 172.16.1.0 0.0.0.255 area 0
r3(config-router)#int s1/0
r3(config-if)#ip ospf network point-to-point

状態を確認します。

r3#show ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:00:30    172.16.1.1      Serial1/0

r3#show ip ospf database

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         29          0x80000004 0x00AA45 4
2.2.2.2         2.2.2.2         183         0x80000002 0x0028EB 2
3.3.3.3         3.3.3.3         28          0x80000002 0x00FD0C 2

r3#show ip route ospf
     172.16.0.0/24 is subnetted, 2 subnets
O       172.16.0.0 [110/128] via 172.16.1.1, 00:00:28, Serial1/0

まとめ

Dynagen、Dynamips を使って、フレームリレーを練習しました。
果たして実地でフレームリレーに出会うことはあるのでしょうか。

GitHubで編集を提案

Discussion

ログインするとコメントできます