🗂

【Flutter】「注意:詳細は、-Xlint:deprecationオプションを指定して再コンパイルしてください。」がでたときの対処

2021/05/27に公開約600字

はじめに

エラー対処系です。

この記事を読むとわかること

FlutterでFireStoreを使用するとたまに出る下記のエラーの対処方法がわかります。

注意:詳細は、-Xlint:deprecationオプションを指定して再コンパイルしてください。

本編

下記ファイルを更新するだけで直ります。

/android/app/build.gradle
    defaultConfig {
        // TODO: Specify your own unique Application ID (https://developer.android.com/studio/build/application-id.html).
        applicationId "com.example.jiro_map_sm"
        minSdkVersion 25 ⇐ 25に変更(もともと16だった)
        targetSdkVersion 30
        versionCode flutterVersionCode.toInteger()
        versionName flutterVersionName
    }

今回は"25"に変更しましたが、それでもエラーが消えない場合は更に大きい数字に変えると思われます。

Discussion

ログインするとコメントできます