🐥

M1 Macでfirebase-adminがインストールできない問題

2022/03/10に公開約700字

根が深い問題みたいですね。私は以下で解決したという備忘録です。

$ LDFLAGS="-L/opt/homebrew/opt/protobuf/lib -L/opt/homebrew/opt/zlib/lib -L/opt/homebrew/opt/openssl/lib" CFLAGS="-I/opt/homebrew/opt/protobuf/include -I/opt/homebrew/opt/zlib/include -I/opt/homebrew/opt/openssl/include" GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1 GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1 pipenv install firebase-admin

システムのPythonではなく、PyenvでインストールしたPythonです。環境はこちらです。

❯ python -V
Python 3.9.7
❯ which python
/Users/xxx/yyyy/.venv/bin/python
❯ file $(which python)
/Users/xxx/yyy/.venv/bin/python: Mach-O 64-bit executable arm64
❯ pip -V
pip 22.0.3 from /Users/xxx/yyy/.venv/lib/python3.9/site-packages/pip (python 3.9)
❯ which pip
/Users/xxx/yyy/.venv/bin/pip

Discussion

ログインするとコメントできます