📘

future build failures, try to migrate this app to the V2 embeddingを消す

2022/04/27に公開約600字

環境

Flutter 2.10.5
Dart 2.16.2
Visual Studio Code 1.66.2

現象

flutter pub getを実行すると、下記の警告が発生


This app is using a deprecated version of the Android embedding.
To avoid unexpected runtime failures, or future build failures, try to migrate this app to the V2 embedding.
Take a look at the docs for migrating an app: https://github.com/flutter/flutter/wiki/Upgrading-pre-1.12-Android-projects

原因

Flutter V2の出現により、
io.flutter.app.FlutterActivityに関連するClassが非推奨になったためです。

解決策

[アプリケーション名]/android/app/src/main/AndroidManifest.xmlのファイルの中身を下記のように修正します。

Before

android:name="io.flutter.app.FlutterApplication"

After

android:name="${applicationName}"

Discussion

ログインするとコメントできます