💊

【Laravel】既存プロジェクトにsailをインストールさせようとした時のエラー

2022/12/18に公開約1,100字

開発環境

  • Laravel Framework 9.13.0
  • php 8.2
  • docker

エラー内容

開発プロジェクトにsailのインストールを行おうと下記のコマンドを実行。

composer require laravel/sail --dev

実行後下記のエラーが出力された。

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - phpspec/prophecy v1.15.0 requires php ^7.2 || ~8.0, <8.2 -> your php version (8.2.0) does not satisfy that requirement.
    - phpunit/phpunit 9.5.20 requires phpspec/prophecy ^1.12.1 -> satisfiable by phpspec/prophecy[v1.15.0].
    - phpunit/phpunit is locked to version 9.5.20 and an update of this package was not requested.

You can also try re-running composer require with an explicit version constraint, e.g. "composer require laravel/sail:*" to figure out if any version is installable, or "composer require laravel/sail:^2.1" if you know which you need.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

どうやらPHPのバージョンが対応していないみたい。

解決方法

PHPのインストール

対応しているPHPのバージョンを@の後ろにつけてインストールする。

brew install php@8.0

PHPのバージョンの切り替え

下記のコマンドを実行し、php8.2からphp8.0に切り替える。

brew unlink php@8.2
brew link php@8.0

Discussion

ログインするとコメントできます