🐛

Failed to start DevTools: Dart DevTools exited with code 255.

2022/01/02に公開約1,000字

エラー

vscodeでDart DevToolsエラーが発生した。

Failed to start DevTools: Dart DevTools exited with code 255.

version

Iterm
❯ flutter --version
Flutter 2.5.3 • channel stable • https://github.com/flutter/flutter.git
Framework • revision 18116933e7 (3 months ago)2021-10-15 10:46:35 -0700
Engine • revision d3ea636dc5
Tools • Dart 2.14.4

❯ dart --version
Dart SDK version: 2.14.4 (stable) (Wed Oct 13 11:11:32 2021 +0200) on "macos_x64"

解決策

現行のDartに梱包されている、devtoolsにバグが含まれているらしい。

1. devtoolsのバージョンをダウングレード

バグが起こる前のバージョンに、devtoolsをダウングレードする。

Iterm
dart pub global activate devtools -v 2.8.0

2. previewバージョンのbugfixされたDartを使う

previewバージョンのDartだと、このバグが修正されているので、previewバージョンのDartを使うようにする。

参考

https://github.com/flutter/devtools/issues/3549
https://stackoverflow.com/questions/70446275/failed-to-start-devtools-dart-devtools-exited-with-code-255

Discussion

ログインするとコメントできます