Android Studio4.1にupdateしたら何故かflutter doctorでwarningが出た話

1 min read読了の目安(約800字

概要および事象

Android Studio4.1にupdateし、念のためflutter doctorを実行したところ、 Android Studioで下記のwarningが発生しました。

flutterのバージョンは1.22.0です

内容的にFlutterとDartのプラグインがインストールされていないとありますが、画面キャプチャの通り、インストールされていますし、Android Studio上でアプリも動いているのでなんでだとなりました。

FlutterとDartのプラグインはインストールされていることを確認(画面キャプチャ)

調査(確認)結果

issueに挙がっていないか調べたところ既にありました。
なお、このwarningは下記のissueでも語られている通り特に対応は不要のようです。

https://github.com/flutter/flutter/issues/67986#issuecomment-707881534
また、こちらのPRで対応済でした。
https://github.com/flutter/flutter/pull/68168

なかなかびっくりしましたがissue確認してみるのは大事ですね。
知らなかったら無駄に調査することになっていました😅

参考

https://github.com/flutter/flutter/issues/68180
https://github.com/flutter/flutter/issues/67986
https://github.com/flutter/flutter/pull/68168