👌

AmazonLinux2 kernel ダウングレード

2023/02/24に公開

はじめに

kernel updateで最新バージョンを適用した際に、DeepSecurityAgentの対応外バージョンになってしまったため、実施しました。

環境

OS: 4.14.198-152.320.amzn2.x86_64
DSA: 20.0.0.3288

手順

アップデート

# アップデート
yum update kernel*
reboot
uname -r

# ダウングレードするバージョンを確認
yum --showduplicates search kernel

yum install kernel-4.14.296-222.539.amzn2.x86_64

ダウングレード

# デフォルト確認
grubby --default-kernel

# ダウングレードするKernelのパスを確認
grubby --info=ALL

# Kernelのパスを入力
grubby --set-default=/boot/vmlinuz-4.14.296-222.539.amzn2.x86_64

# 変更確認
grubby --default-kernel

# リブート
reboot

# 変更されているか確認する
uname -r

参考

https://help.deepsecurity.trendmicro.com/20_0/on-premise/ja-jp/agent-linux-kernel-support.html

https://aws.amazon.com/jp/premiumsupport/knowledge-center/revert-stable-kernel-ec2-reboot/

Discussion

ログインするとコメントできます