😑

primary' は非推奨!

2023/01/06に公開約700字

この機能はv3.1.0以降で非推奨となりました

ElevatedButtonの色を変えようとすると最近、primaryに棒線が弾かれる現象が起きるようになりました!
どうやら非推奨になってしまったようです!

非推奨になったコード

マウスをホバーすると、英語でメッセージが出てきました!

primary' is deprecated and shouldn't be used. Use backgroundColor instead. This feature was deprecated after v3.1.0.. (Documentation)
翻訳
primary' は非推奨であり、使うべきではありません。代わりに backgroundColor を使ってください。この機能はv3.1.0以降で非推奨となりました... (Documentation)

変更されたコード

なので、こちらのコードに修正してください。

最後に

Flutterも日々進化していて、Widgetの設定をするコードが突然非推奨になったりするから、アンテナを常に張っていないと、変更点に気づかないですね!
Flutterニュースを毎日チェックしないと進化に置いて行かれてしまう。

Discussion

ログインするとコメントできます