terser-webpack-pluginのv5系ではwebpackのv4系をサポートしていないので注意

1 min read読了の目安(約400字

vue-cliを使用して、構築した場合、記事執筆時点だと、webpackのv4系が利用されます。
この時に、terser-webpack-pluginをv5系にUpgradeしてビルドをすると以下のエラーが表示される。

TypeError: Cannot read property 'javascript' of undefined

以下に記載されている通り、webpackのv4系はサポートされていないので、terser-webpack-pluginのv4系を利用する必要がある。(terser-webpack-plugin:Releases