🐙

【CircleCI】aws-ecr OrbのInstall AWS CLIでpip updateを要求するエラーが出た時に確認すること

1 min read

起きたこと

aws-ecr/build_and_push_image の Install AWS CLI で下記エラー

RequirementParseError: Expected ',' or end-of-list in rsa>=3.1.2,<=4.5.0; python_version=="2.7" at ; python_version=="2.7"
You are using pip version 8.1.1, however version 21.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

読んだ限りではエラーは 1 行目だけで、2,3 行目は「pip のバージョンが古いから upgrade した方がいい」的なことが書いてあります。
1 行目のエラーの解決方法も、一見しただけでは何かわかりませんでした。

解決方法

aws-ecr orb のバージョンを最新にする

です。
必ずしも最新である必要はなく、6.15.3以上であればいいようです。

参考文献

https://support.circleci.com/hc/en-us/articles/360059057832-AWS-CLI-install-failing-when-using-aws-ecr-orb

Discussion

ログインするとコメントできます