📓

embulkのgem installでRuby version >= 2.4.0と出た時は

1 min read

embulkgem install 時プラグインによっては以下のようなエラーがでることがあります。
Embulk 0.9.23に入っているJRubyのバージョンは9.1.5.0で、Ruby 2.3互換となっており、Ruby 2.4互換ではないのでこのようなエラーが出ます。

ERROR:  Error installing embulk-input-google_analytics:
	representable requires Ruby version >= 2.4.0.

新しいバージョンのプラグインがリリースされるまで、以下のような順序でコマンドを実行するとプラグインがインストールできます。
(なお動作確認まではおこなっていません。)

その他インストールできないプラグンがあったらお知らせください。Google 関連のサービスは同じようなエラーが出ますが、同じ手順でインストールできるかと思います。

embulk-output-bigquery

以下の問題は、embulk-output-bigquery 0.6.5で修正されています。(まだ出るなら他の不具合です)

embulk gem install representable -v 3.0.4
embulk gem install faraday -v 0.17.4
embulk gem install embulk-output-bigquery

embulk-intput-elasticsearch

embulk gem install faraday -v 0.17.4
embulk gem install elasticsearch -v 7.5.0
embulk gem install embulk-input-elasticsearch

embulk-input-google_analytics

embulk gem install representable -v 3.0.4
embulk gem install faraday -v 0.17.4
embulk gem install embulk-input-google_analytics

Discussion

ログインするとコメントできます