📝

flutterfire configure が全く動かない謎のエラーはファイル名に問題があった

2023/01/12に公開約900字
コマンド
flutterfire configure

を打った時に出たエラーがこちら

翻訳:FirebaseCommandException: Firebase CLI でコマンドを実行しようとした際にエラーが発生しました。

ふむ。よく分からん。なんこれ。

まぁ調べれば分かるっしょ。グーグル先生って天才だしなんでも答えてくれるはず!

とか思ったけど、エラー内容がざっくりし過ぎてて色々な関係のない記事しか出てこない。

Androidだけ上手くいってた。

謎過ぎて、どうして良いか分からなかったけど、
Firebaseをちゃんと見ると、Androidだけは謎に上手くいっていた。

なんでだぁぁぁとか思ったけど、
面倒なので、とりま手動で作ってファイルも手動で入れようとした結果

ほへぇぇぇ。なんこれ。
知らなんだ。

これか原因。

で、XCodeを開いてみると

こうなっとった。

ファイル生成時は、

youtube_api_test

みたいな感じで作成したけど、iOSの方のバンドルIDが変化するなんて思いも寄らなかった。

もう面倒なので、「-」とか「_」とかは使わない。

これに尽きる。

確か逆に、ハイフンとかはAndroidで使えなかったはず。。。面倒すぎ。統一してくれ。

追記

コマンド
dart pub global activate flutterfire_cli

上記のコマンド打ったらCLIのバージョンが上がって全部自動で反映されるようになった。すご。

Discussion

ログインするとコメントできます