⚡️

electron-builder で rebuilding native dependencies から先に進まない

2022/01/23に公開約500字

問題

以下のコマンドでビルドを実行する。

npx electron-builder --mac

すると以下のメッセージを表示後、先に進まない。

rebuilding native dependencies dependencies=fsevents@1.2.13 platform=darwin arch=arm64

対策

  1. npm exec electron-builder --mac を使う。
  2. package.jsonのscriptsに "build": "electron-builder" を追加し、npm run buildを実行する。

ノート

electron-builderでは環境に応じたパッケージマネージャ(npm/yarn)を利用する。
npxコマンドから実行するとパッケージマネージャを識別できにずに上手く動作しない。


参考

https://github.com/electron-userland/electron-builder/issues/6411
GitHubで編集を提案

Discussion

ログインするとコメントできます