🐚

ssh: ...no version information available

2022/04/18に公開約2,200字

環境

  • Ubuntu 16.04 LTS

エラー:

/usr/bin/ssh: /usr/local/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/ssh)
/usr/bin/ssh: /usr/local/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/ssh)

原因

なんらかのコンパイルで、生成されたsoファイルにはversion情報がないため、エラーメッセージがでます。Ubuntu中のsoファイルにはversion情報がありますので、そちらシンポリックリンクします。

openssl情報を確認

ldd /usr/bin/openssl
/usr/bin/openssl: /usr/local/lib/libssl.so.1.0.0: no version information available (required by /usr/bin/openssl)
/usr/bin/openssl: /usr/local/lib/libssl.so.1.0.0: no version information available (required by /usr/bin/openssl)
/usr/bin/openssl: /usr/local/lib/libssl.so.1.0.0: no version information available (required by /usr/bin/openssl)
/usr/bin/openssl: /usr/local/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/openssl)
/usr/bin/openssl: /usr/local/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/openssl)
/usr/bin/openssl: /usr/local/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/openssl)
/usr/bin/openssl: /usr/local/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/openssl)
        linux-vdso.so.1 =>  (0x00007ffc6c3b1000)
        libssl.so.1.0.0 => /usr/local/lib/libssl.so.1.0.0 (0x00007fdd0b4ba000)
        libcrypto.so.1.0.0 => /usr/local/lib/libcrypto.so.1.0.0 (0x00007fdd0b05f000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fdd0ac95000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fdd0aa91000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fdd0b72d000)

Ubuntuのsoファイルは、/lib/x86_64-linux-gnuにあるでしょう。

Ubuntuのsoファイルを確認

ls -l /lib/x86_64-linux-gnu/libssl.so.1.0.0
ls -l /lib/x86_64-linux-gnu/libcrypto.so.1.0.0

対処

# libssl.so.1.0.0:
sudo mv /usr/local/lib/libssl.so.1.0.0 /usr/local/lib/libssl.so.1.0.0.bak
sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 /usr/local/lib/libssl.so.1.0.0

# libcrypto.so.1.0.0:
sudo mv /usr/local/lib/libcrypto.so.1.0.0 /usr/local/lib/libcrypto.so.1.0.0.bak
sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/local/lib/libcrypto.so.1.0.0

以上です。

Discussion

ログインするとコメントできます