🍄

npm install -g truffle にコケた時の対処法

2022/03/26に公開約200字

TL;DR

npmのバージョンを6.xにする。
現状、truffleがnpm >= v7.xに対応していないようです。

解決方法

npm -g install npm@6

以上です。
直近のtruffleのイシューはインストールに関連する内容が多そうなので、随時チームが対応してくれて、アップデートがありそうです。

参考サイト

https://github.com/trufflesuite/truffle/issues/4865

Discussion

ログインするとコメントできます