⚙️

【WSL2】JetBrains系IDEからasdfのYarnを使う方法

1 min read

環境

ツール バージョン
OS Ubuntu 20.04.2 LTS (WSL2)
IDE IntelliJ IDEA 2021.1.1 (Ultimate Edition)
Node.js v15.8.0
Yarn 1.22.10

前提条件

  • IDEは普通にWindows上にインストールしている
  • Node.jsをasdfでインストールしている
  • Yarnをasdf-yarnでインストールしている
  • WSL2のUbuntu側のファイルシステムに置いたソースをIntelliJやWebStormなどのIDEで開いている

手順

設定のLanguages & Frameworks -> Node.js and NPMで以下のように設定すればOK
※塗りつぶし部分はユーザー名

これでIDEからYarnを使えるようになる

ちなみにYarnではなくnpmを使いたい場合はコレでいける

参考

npm is not recognized with node installed via asdf : WEB-39858