🙃

Expo SDK を 44→47 に upgrade した際のエラー解消メモ

2022/11/27に公開約500字

monorepo で開発しており、フロントエンド用のワークスペースを利用していますが、monorepo かどうかは関係なさそうです。

まずは対象のワークスペースに移動します。

cd /frontend

ここで下記がすんなり通れば問題ないのですが・・・

expo upgrade

下記のエラーが出て失敗します。これは yarn 側のエラーなので、自身の環境の問題である可能性が高いです。
yarnpkg exited with non-zero code: 1

Stack Overflow にも上がっており、私の方ではこちらを一通り試しましたが解決せず。
https://stackoverflow.com/questions/63829104/failed-to-install-expo-package-with-error-yarnpkg-exited-with-non-zero-code-1/72332470#72332470

最終的に各パッケージをアップデートして成功しました。

yarn upgrade
expo upgrade

さらに各パッケージを必要に応じて手動でアップデートしなければいけないようですが、そちらは別記事で。

Discussion

ログインするとコメントできます