Open9

ansible-core 2.12 / ansible 5 関連メモ

コントロールノードで Python 3.8 以上が必要に

Python Controller Requirement - Python 3.8 or newer is required for the control node (the machine that runs Ansible) (https://github.com/ansible/ansible/pull/74013)

ansible-core 2.11 では警告止まりだった。

ドキュメントのインストール方法の記述にも反映されている。

For your control node (the machine that runs Ansible), you can use any machine with Python 3.8 or newer installed.

https://docs.ansible.com/ansible-core/2.12/installation_guide/intro_installation.html#control-node-requirements

interpreter descovery 仕様変更・機能追加

Python 3 優先

interpreter discovery - prefer Python 3 over Python 2

INTERPRETER_PYTHON_FALLBACK を変数で変更可能に

interpreter discovery - allow the default list of INTERPRETER_PYTHON_FALLBACK to be changed using a variable

関連設定項目: INTERPRETER_PYTHON_FALLBACK

関連 PR

https://github.com/ansible/ansible/pull/75049

ポーティングガイドより

The default value of INTERPRETER_PYTHON_FALLBACK changed to auto. The list of Python interpreters in INTERPRETER_PYTHON_FALLBACK changed to prefer Python 3 over Python 2. The combination of these two changes means the new default behavior is to quietly prefer Python 3 over Python 2 on remote hosts. Previously a deprecation warning was issued in situations where interpreter discovery would have used Python 3 but the interpreter was set to /usr/bin/python.

https://docs.ansible.com/ansible-core/2.12/porting_guides/porting_guide_core_2.12.html#python-interpreter-discovery

ansible-core 2.11 では auto_legacy がデフォルトだったが、2.12 では auto

メモ minor change までみた

ログインするとコメントできます