ansible-core 2.12 / ansible 5 関連メモ

コントロールノードで Python 3.8 以上が必要に

Python Controller Requirement - Python 3.8 or newer is required for the control node (the machine that runs Ansible) (

ansible-core 2.11 では警告止まりだった。


For your control node (the machine that runs Ansible), you can use any machine with Python 3.8 or newer installed.

interpreter descovery 仕様変更・機能追加

Python 3 優先

interpreter discovery - prefer Python 3 over Python 2


interpreter discovery - allow the default list of INTERPRETER_PYTHON_FALLBACK to be changed using a variable


関連 PR


The default value of INTERPRETER_PYTHON_FALLBACK changed to auto. The list of Python interpreters in INTERPRETER_PYTHON_FALLBACK changed to prefer Python 3 over Python 2. The combination of these two changes means the new default behavior is to quietly prefer Python 3 over Python 2 on remote hosts. Previously a deprecation warning was issued in situations where interpreter discovery would have used Python 3 but the interpreter was set to /usr/bin/python.

ansible-core 2.11 では auto_legacy がデフォルトだったが、2.12 では auto

メモ minor change までみた