Closed11

2021年4月の気になりAnsible

tower_workflow_job_template モジュールの schema オプション

tower_workflow_job_template モジュールで、直接ワークフロービジュアライザー相当のオプションをつけるPR。

これまでは別途tower_workflow_job_template_node でやっていたけれど。直接できると便利そう。

https://github.com/ansible/awx/pull/9309

Ansible と Python 3.8

ROADMAP の 説明

ansible-core==2.12 will include breaking changes requiring at least Python 3.8.

https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_11.rst#id4

For your control node (the machine that runs Ansible), you can use any machine with Python 2 (version 2.7) or Python 3 (versions 3.5 and higher) installed. ansible-core 2.11 and Ansible 4.0.0 will make Python 3.8 a soft dependency for the control node, but will function with the aforementioned requirements. ansible-core 2.12 and Ansible 5.0.0 will require Python 3.8 or newer to function on the control node. Starting with ansible-core 2.11, the project will only be packaged for Python 3.8 and newer.

インストレーション

https://docs.ansible.com/ansible/latest/installation_guide/intro_installation.html#control-node-requirements

https://github.com/ansible/ansible/issues/72668

ansible 2.11.b0 changelog

https://github.com/ansible/ansible/blob/stable-2.11/changelogs/CHANGELOG-v2.11.rst#id14

Add warning for Ansible 2.11 when running a Python version older than Python 3.8 to inform users that 2.12 will only support Python 3.8 and newer on the controller. Starting with Ansible 2.11, the project will only be packaged for Python 3.8 and newer.

関連 warning

CONTROLLER_PYTHON_WARNING:
  name: Running Older than Python 3.8 Warning
  default: True
  description: Toggle to control showing warnings related to running a Python version
               older than Python 3.8 on the controller
  env: [{name: ANSIBLE_CONTROLLER_PYTHON_WARNING}]
  ini:
  - {key: controller_python_warning, section: defaults}
  type: boolean

https://github.com/ansible/ansible/pull/72467/files

おためし

https://twitter.com/akira6592/status/1381076267785625600
このスクラップは2021/04/30にクローズされました
作成者以外のコメントは許可されていません