Laravelをcomposerでインストールする方法

1 min read読了の目安(約600字

はじめに

Laravelをcomposerでインストール方法についてまとめました

Laravelをcomposerでインストールする

バージョン指定なし(最新バージョンがインストールされます)

$ composer create-project laravel/laravel --prefer-dist laravel-latest
$ php laravel-latest/artisan -V
Laravel Framework 8.32.1

メジャーバージョンを指定する(指定したバージョンの最新がインストールされます)

$ composer create-project laravel/laravel --prefer-dist laravel-7.x "7.x"
$ php laravel-7.x/artisan -V
Laravel Framework 7.30.4

まとめ

Laravelをcomposerでインストールする方法についてまとめました
バージョン指定しないと、最新バージョンでインストールされます
そのため、バージョン違いによる不具合が生じる可能性があるため、Laravelをインストールする際はバージョンを指定することをオススメします