📚

【Flutter】"A package may not list itself as a dependency." が発生するケース

2023/01/25に公開

概要

Flutterでpub getを実行したときに、pubspec.yaml: A package may not list itself as a dependency.が発生しました。

以下は発生した理由についての備忘録です。

エラーの発生理由

遭遇したケースでは、pubspec.yamlの最初に設定しているnameと追加したいパッケージ名が重複したために、上記のエラーが発生していました。

例)

name: foo

dependencies:
  foo: ^0.0.1

Discussion

ログインするとコメントできます