👻

【Rails】Failed to start Solargraph: Gem::LoadError: solargraph is~

2022/06/21に公開

エラー文

VSCode起動時に↓が出る
Failed to start Solargraph: Gem::LoadError: solargraph is not part of the bundle. Add it to your Gemfile

対処

このエラー文自体はsolargraphをgemfileに入れて、bundle installして、pathを通して〜
という対処ができるが、環境のRubyバージョンを古いままにする必要があり不可。
しかし、solargraphを無効化しようとすると Railsに依存しています のように出る。

しばらく気づかなかったのですが、 ここでいう Rails はVSCode拡張機能の Rails でした。
Ruby on Railsに必須のgem名ではなかった。
元々js.erbのファイルにシンタックスハイライトを効かせたかったのですが、
solargraphだとこのエラーが出るみたいですので、別のgemを入れて対処。

VSCode拡張の Railssolargraph はアンインストールして解決。

Discussion

ログインするとコメントできます