【Flutter】Android Studioのdevice selectionでiosシミュレーターが選択できない問題

1 min read読了の目安(約1100字

経緯

【初心者向け超入門】MacでFlutterの環境構築(iOS/Androidアプリ開発,プログラミング)
上記動画に従って環境構築を行っていたところ以下の箇所(iPhone 12 Pro ~)が"<no devices>"となり、
Flutter Device Selectionでiosシミュレーターを選択できない問題が発生。
Androidデバイスは選択できるのに。。。

原因を探る

$ flutter doctor
✗ Flutter plugin not installed; this adds Flutter specific functionality.
✗ Dart plugin not installed; this adds Dart specific functionality.

Preferencesからプラグインを入れているはずなのにインストールされてないことになってる。。。

解決法

$ ln -s ~/Library/Application\ Support/Google/AndroidStudio4.1/plugins ~/Library/Application\ Support/AndroidStudio4.1

Flutter plugin not installed error;. When running flutter doctor
上記記事に記載のコマンドを実行し解決。
【 ln 】コマンド――ファイルのハードリンクとシンボリックリンクを作る
lnコマンドでシンボリックリンクとやらを作成することによって解決したみたい。
パスを通すみたいな話か。


編集後記

Stack Overflowはすごい。