🥺

M1でnode-sassが使えなかったお話

commits1 min read 2

win 環境で開発していた Redux Toolkit のプロジェクトを M1 にクローンしてyarn startしたところ、node-sassはまだM1に対応していよと怒られました。

自分と同じように困っている方に役立てば幸いです。

調べていると、参考になったページがあったので載せておきます。

https://shimi-shin.com/programming/web/m1-mac-node-sass/

sassとsass-loaderで代用できるみたいなので、node-sassをアンインストールして

yarn remove node-sass

sassとsass-loaderをインストールしましょう

yarn add sass sass-loader

これでM1で開発ができます!

GitHubで編集を提案

Discussion

install has been replaced with add to add new dependencie とのことで以下コマンドになったようです。

yarn add sass sass-loader

ありがとうございます!タイポでした😖

ログインするとコメントできます