🐙

yarn install できない場合

2024/07/10に公開

PowerShellの実行ポリシーの問題

PS C:\Users\user\aso-em-frontend-meibo> yarn install
yarn : このシステムではスクリプトの実行が無効になっているため、ファイル C:\Users\user\AppData\Roaming\npm\yarn.ps1 を読み込むことができません。詳細については、「about_Execution_Policies」(https:/
/go.microsoft.com/fwlink/?LinkID=135170) を参照してください。
発生場所 行:1 文字:1
+ yarn install
+ ~~~~
    + CategoryInfo          : セキュリティ エラー: (: ) []、PSSecurityException
    + FullyQualifiedErrorId : UnauthorizedAccess

というエラーが発生すると、powershellを管理者として実行して

Set-ExecutionPolicy RemoteSigned

後「Y」入力で解決!

packageManagerの問題

This project's package.json defines "packageManager": "yarn@npm@10.2.4". However the current global version of Yarn is 1.22.22.

というエラーが発生すると、package.jsonの

"packageManager": "npm@10.2.4"

を削除することで解決!

Discussion