Open6

flutterがくしゅうちょう

androidの環境構築

android studioをcommand line toolsをダウンロードして、パス通してsdkmanagerをシェルに打てば何かうごくはず→

Error: Could not determine SDK root.
Error: Either specify it explicitly with --sdk_root= or move this package into its expected location: <sdk>/cmdline-tools/latest/

ってエラーが出る

所定のディレクトリに移したうえで、binが入ってるcmdline-toolsフォルダをlatestって名前に変更する必要があるみたい

https://stackoverflow.com/questions/65262340/cmdline-tools-could-not-determine-sdk-root

windowsでflutterの環境構築しようとして、

  • flutterがわからないのか
  • windowsがわからないのか
  • wslがわからないのか
  • ubuntuがわからないのか
  • android studioがわからないのか

ってなってる

wslでエミュレーターうごかすのがしんどいので、普通に windows / mac に環境構築するのがよさそう

windowsに環境構築したらすぐできた
powershellを敬遠してたので、プロジェクトフォルダ自体はwsl配下に置きたかったが、どうやらファイルパスに問題が発生してflutter runがうごかない

はらくくってpowershell使う前提でwindowsで開発することにしたが、意外とbashと構文にてそう?だから案外大丈夫だった

flutterは flutter run ではホットリロードが効かない
vscodeから起動しているときは、コマンドパレットでAttach to Flutter on Deviceを選択

ログインするとコメントできます